[pgpool-general: 3139] user setup issue

Megan . nagemnna at gmail.com
Wed Sep 3 21:35:01 JST 2014

Good Morning,

I apologize for asking a simple question, but I cannot seem to sort
out what i've done wrong.  I read
http://www.pgpool.net/docs/latest/pgpool-en.html#md5 and
http://www.pgpool.net/docs/latest/pgpool-en.html#hba but i still get
an error when my user tries to connect.

Server:  xxx.xxx.xxx.20
Client:   xxx.xxx.xxx.33

The client trying to connect into pgpool:

[user at mgmt1-sit ~]$ psql -h xxx.xxx.xxx.33 -p 9999 -U tie tie

In the log I see:
2014-09-03 12:18:08 LOG:   pid 3819: pool_do_auth: maybe protocol
version mismatch (current version 3)

I read that this has to do with postgres's configuration for the user
vs. pgpool.  I tried everything i could but i can't get the user to

I added the user into pool_passwd with pg_md5

[root at db1-sit pgpool-II]# cat pool_passwd

i added the below into pool_hba.conf

host    tie             tie             xxx.xxx.xxx.33/32         md5

The user/role exists in the postgres database with the same password
as was using in pool_passwd

I have the following in pg_hba.conf:

host   tie              tie          xxx.xxx.xxx.20/32        trust
local   tie     tie                             md5

pgpool and postgres have been restarted.

I've tried changing he host from trust to md5, i've removed the local
entry, tried every combination I can think of, but I still can't get
the user logged in.

Any help?

Thank you so much in advance.

More information about the pgpool-general mailing list