View Issue Details

IDProjectCategoryView StatusLast Update
0000611Pgpool-IIBugpublic2020-05-15 17:07
ReporterobsdbaAssigned Tot-ishii 
PriorityurgentSeveritycrashReproducibilityrandom
Status closedResolutionopen 
PlatformLinux OSRed Hat OS Version7.7
Product Version4.1.0 
Target VersionFixed in Version 
Summary0000611: segmentation fault
DescriptionHello,
We usually get the following error messages on our production server :
May 1 15:37:58 igoprdb02 kernel: [68127.511087] pgpool[18594]: segfault at 231 ip 00000000004502a5 sp 00007ffef047c690 error 4 in pgpool[400000+1f8000]
type=ANOM_ABEND msg=audit(1588340278.304:3338): auid=4294967295 uid=26 gid=26 ses=4294967295 pid=18594 comm="pgpool" reason="memory violation" sig=11

In the attachment you can find : configuration files and coredump file

Thanks for your support
Additional Informationpostgresql version : 10.11
Total amount of RAM : 11GB
TagsNo tags attached.

Activities

obsdba

2020-05-05 02:18

reporter  

core-systemd-journal.921.prdb02.1588371458 (1,847,296 bytes)
postgresql.conf (23,161 bytes)
pgpool.conf (43,687 bytes)

t-ishii

2020-05-05 09:19

developer   ~0003357

Can you show the back trace? I cannot handle the core file. I am not familiar with systemd but I think you can take a back trace something like:
coredumpctl gdb -1

obsdba

2020-05-12 01:13

reporter   ~0003362

Hello,
By analyzing the core dump file we saw that it was generated by systemd and therefore we had opened a ticket at redhat.
Thanks for your attention

t-ishii

2020-05-12 09:03

developer   ~0003363

May I close this issue?

obsdba

2020-05-15 17:00

reporter   ~0003367

Hello
We applied a fix to Redhat systemd and since the error has not happened again.
This case can be closed now.
Thanks for your attention.

t-ishii

2020-05-15 17:06

developer   ~0003368

Thanks for the confirmation!

Issue History

Date Modified Username Field Change
2020-05-05 02:18 obsdba New Issue
2020-05-05 02:18 obsdba File Added: pgpool.conf
2020-05-05 02:18 obsdba File Added: postgresql.conf
2020-05-05 02:18 obsdba File Added: core-systemd-journal.921.prdb02.1588371458
2020-05-05 09:19 t-ishii Note Added: 0003357
2020-05-06 15:28 t-ishii Assigned To => t-ishii
2020-05-06 15:28 t-ishii Status new => feedback
2020-05-12 01:13 obsdba Note Added: 0003362
2020-05-12 01:13 obsdba Status feedback => assigned
2020-05-12 09:03 t-ishii Note Added: 0003363
2020-05-15 09:25 t-ishii Status assigned => feedback
2020-05-15 17:00 obsdba Note Added: 0003367
2020-05-15 17:00 obsdba Status feedback => assigned
2020-05-15 17:06 t-ishii Note Added: 0003368
2020-05-15 17:07 t-ishii Status assigned => closed