View Issue Details

IDProjectCategoryView StatusLast Update
0000581Pgpool-IIBugpublic2020-01-30 09:05
ReporterMatAssigned Topengbo 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionopen 
Product Version4.1.0 
Target VersionFixed in Version 
Summary0000581: Pgpool release VIP
DescriptionHi,

I am trying to setup a 2 nodes cluter with load balancing, failoer and VIP.
1- I start pgpool on the node 1
2- I start pgpool on the node 2
3- I got a vIP for a short time
4- The vIP is released

Do you have any idea of where is the problem ? (I attach the pgpool.conf if it can help you..)

Thanks in advance,

Mat
Additional Informationnode 1 : 10.0.9.209
node 2 : 10.0.9.210
virtual ip : 10.0.9.211

system : Centos 8
Postgre version : 11
Pgpool version : 4.1
TagsNo tags attached.

Activities

Mat

2020-01-28 20:14

reporter  

logs pgpool 1.png (103,918 bytes)
logs pgpool 1.png (103,918 bytes)
pgpool_1.conf (43,399 bytes)

pengbo

2020-01-29 09:47

developer   ~0003098

> FATAL: failed to bind a socket: "/tmp/.s.PGSQL.9999"

It seems that pgpool process failed because the socket file exists.
Please remove the existing socket file and restart pgpool again.

# rm /tmp/.s.PGSQL.9*
# systemctl start pgpool

Mat

2020-01-29 23:14

reporter   ~0003106

Okay, it work, thanks a lot !
You can close the issue.

Issue History

Date Modified Username Field Change
2020-01-28 20:14 Mat New Issue
2020-01-28 20:14 Mat File Added: pgpool_1.conf
2020-01-28 20:14 Mat File Added: logs pgpool 1.png
2020-01-29 09:43 pengbo Assigned To => pengbo
2020-01-29 09:43 pengbo Status new => assigned
2020-01-29 09:43 pengbo Description Updated View Revisions
2020-01-29 09:43 pengbo Additional Information Updated View Revisions
2020-01-29 09:47 pengbo Note Added: 0003098
2020-01-29 09:48 pengbo Status assigned => feedback
2020-01-29 23:14 Mat Note Added: 0003106
2020-01-29 23:14 Mat Status feedback => assigned
2020-01-30 09:05 pengbo Status assigned => closed