View Issue Details

IDProjectCategoryView StatusLast Update
0000575Pgpool-IIIncompatible changepublic2020-01-29 13:35
ReporterangelosAssigned Tot-ishii 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionopen 
Product Version4.1.0 
Target VersionFixed in Version 
Summary0000575: cannot bring streaming slave online
DescriptionCannot bring slave online with streaming replication
OS is Debian Buster latest

pgpool version 4.1.0-1.pgdg100+1
pgpool-II error
FATAL: Backend throw an error message
DETAIL: Exiting current session because of an error from backend
HINT: BACKEND Error: "recovery is in progress"
CONTEXT: while checking replication time lag


postgres version 12.1-1.pgdg100+1
postgres error

postgres[24879]: [7-3] 2020-01-10 12:19:49.580 CET [24879] healthcheck@postgres STATEMENT: SELECT pg_current_wal_lsn()
postgres[24878]: [8-1] 2020-01-10 12:19:51.501 CET [24878] healthcheck@postgres LOG: could not receive data from client: Connection reset by peer
postgres[24882]: [7-1] 2020-01-10 12:19:51.506 CET [24882] healthcheck@postgres ERROR: recovery is in progress

Steps To Reproduceset up pgpool against postgres 12 native streaming replication with hot_standby
TagsNo tags attached.

Activities

t-ishii

2020-01-15 07:45

developer   ~0003065

Looks like Pgpool-II is not properly configured or streaming replication is not properly set up. Can you share pgpool.log (from starting up) and pgpool.conf?

angelos

2020-01-22 00:43

reporter   ~0003080

Hi there, so I am taking so long to respond, Oddly enough I cannot replicate this error.

pgpool.conf (39,180 bytes)

t-ishii

2020-01-22 15:15

developer   ~0003081

May I close this issue?

angelos

2020-01-22 19:06

reporter   ~0003082

Go ahead and close it

Issue History

Date Modified Username Field Change
2020-01-13 19:12 angelos New Issue
2020-01-15 07:41 t-ishii Assigned To => t-ishii
2020-01-15 07:41 t-ishii Status new => assigned
2020-01-15 07:45 t-ishii Note Added: 0003065
2020-01-15 07:46 t-ishii Status assigned => feedback
2020-01-22 00:43 angelos File Added: pgpool.conf
2020-01-22 00:43 angelos Note Added: 0003080
2020-01-22 00:43 angelos Status feedback => assigned
2020-01-22 15:15 t-ishii Note Added: 0003081
2020-01-22 15:15 t-ishii Status assigned => feedback
2020-01-22 19:06 angelos Note Added: 0003082
2020-01-22 19:06 angelos Status feedback => assigned
2020-01-29 13:35 t-ishii Status assigned => closed