View Issue Details

IDProjectCategoryView StatusLast Update
0000557Pgpool-IIBugpublic2020-04-14 13:09
ReporternglpAssigned Tot-ishii 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionopen 
PlatformLinuxOSRed HatOS Version7.6
Product Version4.0.7 
Target Version4.0.8Fixed in Version4.0.8 
Summary0000557: Syslog settings ignored
DescriptionHi,

We've detected in pgpool 4.0.7 syslog settings are being ignored/not working. In 4.0.6 it works properly

We've syslog configured exactly like https://www.pgpool.net/docs/latest/en/html/example-cluster.html

If we downgrade packages to 4.0.6 everything works as expected

Let me know if you need anything
Steps To ReproduceFollowing configuration:
log_destination = 'syslog'
syslog_facility = 'LOCAL1'
TagsNo tags attached.

Activities

tmartincpp

2019-11-15 18:58

reporter   ~0002963

Hi,

we have the same issue with pgpool 3.7.12.

Rollbacking to 3.7.11 solves the problem

Our configuration:

log_destination = 'syslog'
syslog_facility = 'LOCAL2'
syslog_ident = 'pgpool-II'

When reloading only the following message:
"Done."

is displayed.

nglp

2019-11-15 19:08

reporter   ~0002964

Looks like to be related to this fix: https://www.pgpool.net/mantisbt/view.php?id=548

Configuring in stderr mode works as expected

t-ishii

2019-11-17 10:50

developer   ~0002965

It appears that there's a packaging issue with 3.7.12 (and other latest minor releases). i.e. it missed to update the configure script when configure.ac (the template file for configure) got updated to solve the issue you reffered. This caused the problem you are seeing with RPM package.

Developers are planning to release updated RPM packages in early next week.

t-ishii

2019-11-19 22:31

developer   ~0002970

Updated RPMs have been just released.

https://pgpool.net/mediawiki/index.php/Main_Page#Pgpool-II_4.1.0.2C_4.0.7.2C_3.7.12.2C_3.6.19.2C_3.5.23_and_3.4.26_RPMs_Update_2_officially_released_.282019.2F11.2F19.29

nglp

2019-11-20 20:57

reporter   ~0002972

thank you, its solved in 4.0.7-2

t-ishii

2019-11-20 21:47

developer   ~0002973

Ok, mark this issue as resolved.

Issue History

Date Modified Username Field Change
2019-11-14 23:48 nglp New Issue
2019-11-15 18:58 tmartincpp Note Added: 0002963
2019-11-15 19:08 nglp Note Added: 0002964
2019-11-17 10:50 t-ishii Note Added: 0002965
2019-11-19 22:29 t-ishii Status new => feedback
2019-11-19 22:29 t-ishii Target Version => 4.0.8
2019-11-19 22:31 t-ishii Note Added: 0002970
2019-11-20 20:57 nglp Note Added: 0002972
2019-11-20 20:57 nglp Status feedback => new
2019-11-20 21:47 t-ishii Note Added: 0002973
2019-11-20 21:47 t-ishii Assigned To => t-ishii
2019-11-20 21:47 t-ishii Status new => resolved
2020-04-14 13:09 administrator Status resolved => closed
2020-04-14 13:09 administrator Fixed in Version => 4.0.8