View Issue Details

IDProjectCategoryView StatusLast Update
0000428Pgpool-IIBugpublic2018-09-05 16:05
Reportert-ishiiAssigned ToMuhammad Usama 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0 alpha1 
Target Version4.0 alpha2Fixed in Version 
Summary0000428: Secure TCP/IP Connections with SSL does not work any more
DescriptionI found that Secure TCP/IP Connections with SSL does not work any more
with 4.0 alpha1.

With 3.7.5 it works if I follow the step in FAQ:

https://pgpool.net/mediawiki/index.php/FAQ#How_can_I_set_up_SSL_for_pgpool-II.3F

t-ishii@tishii-CFSV7-1:~/work/Pgpool-II/current/aaa$ psql -p 11000 -h localhost test
psql -p 11000 -h localhost test
psql (10.5)
SSL connection (protocol: TLSv1.2, cipher: ECDHE-RSA-AES256-GCM-SHA384, bits: 256, compression: off)
Type "help" for help.

test=#

I set up:
ssl = on
ssl_key = '/home/t-ishii/work/Pgpool-II/current/aaa/etc/server.key'
ssl_cert = '/home/t-ishii/work/Pgpool-II/current/aaa/etc/server.crt'
Steps To ReproduceFollow the steps in FAQ.
https://pgpool.net/mediawiki/index.php/FAQ#How_can_I_set_up_SSL_for_pgpool-II.3F
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2018-08-28 10:42 t-ishii New Issue
2018-08-28 10:42 t-ishii Status new => assigned
2018-08-28 10:42 t-ishii Assigned To => Muhammad Usama
2018-09-05 16:05 Muhammad Usama Status assigned => resolved
2018-09-05 16:05 Muhammad Usama Resolution open => fixed
2018-09-05 16:05 Muhammad Usama Note Added: 0002178