View Issue Details

IDProjectCategoryView StatusLast Update
0000027Pgpool-IINew featurepublic2012-11-14 14:59
ReportergustavofnAssigned Tot-ishii 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000027: Pgpool 3.2 memory cache logs
DescriptionI'm using the last version of pgpool 3.2 (snapshot 818bd4b) and memory_cache_enabled is on with shmem.
pgpool is creating a lot of lines like in logfile:
2012-09-25 12:45:55 ERROR: pid 7266: pool_delete_item_shmem_cache: item 2905 was deleted
2012-09-25 12:45:55 ERROR: pid 7266: pool_delete_item_shmem_cache: item 2912 was deleted
...
and
2012-09-25 12:45:39 LOG: pid 7455: pool_reuse_block: blockid: 35
2012-09-25 12:45:40 LOG: pid 7471: pool_reuse_block: blockid: 36

pgpool.log is aroung 16GB per day because that lines. How I supress pgpool to log that lines?
Steps To ReproduceActivate memory_cache_enabled.
TagsNo tags attached.

Activities

t-ishii

2012-09-26 08:05

developer   ~0000092

Have you set memqcache_expire to other than 0? Then it is possible you see:

2012-09-25 12:45:55 ERROR: pid 7266: pool_delete_item_shmem_cache: item 2905 was deleted

UPDATE/INSERT/DELETE tries to remove the entry but the entry has been removed because the entry was expired.

If this is your case, I'm going to suppress the error message because that's not actually an error.

t-ishii

2012-11-14 14:58

developer   ~0000149

Fixed in 3.2.1.

Issue History

Date Modified Username Field Change
2012-09-26 00:50 gustavofn New Issue
2012-09-26 08:05 t-ishii Note Added: 0000092
2012-09-26 08:05 t-ishii Assigned To => t-ishii
2012-09-26 08:05 t-ishii Status new => assigned
2012-11-14 14:58 t-ishii Note Added: 0000149
2012-11-14 14:59 t-ishii Status assigned => resolved