View Issue Details

IDProjectCategoryView StatusLast Update
0000237Pgpool-IIBugpublic2016-08-30 07:34
Reportert-ishiiAssigned ToMuhammad Usama 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAnyOSAnyOS VersionAny
Product Version3.5.3 
Target Version3.5.4Fixed in Version 
Summary0000237: Pgpool-II fails to start if listen_addresses is empty string
DescriptionPgpool-II fails to start if listen_addresses is empty string. Originally reported in [pgpool-general-jp: 1418].
Steps To ReproduceSet listen_addresses = '' and start pgpool-II. This happens in not only 3.5.x. Probably in all supported branches.
Additional Information2016-08-25 17:58:35: pid 2170: FATAL: unable to set options on socket
2016-08-25 17:58:35: pid 2170: DETAIL: fcntl system call failed with error
"Bad file descriptor"
2016-08-25 17:58:35: pid 2168: LOG: pgpool-II successfully started.
version 3.5.3 (ekieboshi)
2016-08-25 17:58:35: pid 2168: LOG: child process with pid: 2170 exits
with status 768
2016-08-25 17:58:35: pid 2168: FATAL: child process exit with fatal error.
exiting pgpool-II
2016-08-25 17:58:35: pid 2173: FATAL: unable to set options on socket
2016-08-25 17:58:35: pid 2173: DETAIL: fcntl system call failed with error
"Bad file descriptor"
TagsNo tags attached.

Activities

Muhammad Usama

2016-08-30 00:09

developer   ~0001029

Fix committed in master, 3.4 and 3.5 branches. Older versions do not have the problem since it was caused by the patch to enable IPV6 support in pgpool-II 3.4

https://git.postgresql.org/gitweb/?p=pgpool2.git;a=commitdiff;h=9fd7256e4bdf9a9fa6b61a3b1d66fcd658dbda70

Issue History

Date Modified Username Field Change
2016-08-29 16:51 t-ishii New Issue
2016-08-29 16:52 t-ishii Assigned To => Muhammad Usama
2016-08-29 16:52 t-ishii Status new => assigned
2016-08-30 00:09 Muhammad Usama Status assigned => resolved
2016-08-30 00:09 Muhammad Usama Resolution open => fixed
2016-08-30 00:09 Muhammad Usama Note Added: 0001029
2016-08-30 07:34 administrator Target Version => 3.5.4