View Issue Details

IDProjectCategoryView StatusLast Update
0000185Pgpool-IIBugpublic2016-05-06 16:45
ReporterwangzhenboAssigned ToMuhammad Usama 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000185: plugs out the network cable,the pgpool will not work。
Descriptionpgpool:3.4.4
postgresql:9.1
postgresql :stream replication
pgpool:use watchdog

node1:master pgpool and primary postgresql
node2:slave pgpooland slave postgresql
node3:slave pgpool and slave postgresql

when I plugs out the network cable of node1,the node2 and node3 will logout the message:

Mar 28 14:26:28 puppetserver pgpool[129249]: [1965-1] 2016-03-28 14:26:28: pid 129249: ERROR: failed to make persistent db connection
Mar 28 14:26:28 puppetserver pgpool[129249]: [1965-2] 2016-03-28 14:26:28: pid 129249: DETAIL: connection to host:"192.168.80.163:5432" failed
Mar 28 14:26:29 puppetserver pgpool[129215]: [222-1] 2016-03-28 14:26:29: pid 129215: LOG: checking pgpool status by heartbeat
Mar 28 14:26:29 puppetserver pgpool[129215]: [222-2] 2016-03-28 14:26:29: pid 129215: DETAIL: pgpool: 1 at "192.168.80.163:5433" status is down
Mar 28 14:26:30 puppetserver pgpool[129249]: [1966-1] 2016-03-28 14:26:30: pid 129249: ERROR: Failed to check replication time lag
Mar 28 14:26:30 puppetserver pgpool[129249]: [1966-2] 2016-03-28 14:26:30: pid 129249: DETAIL: No persistent db connection for the node 1
Mar 28 14:26:30 puppetserver pgpool[129249]: [1966-3] 2016-03-28 14:26:30: pid 129249: HINT: check sr_check_user and sr_check_password
Mar 28 14:26:30 puppetserver pgpool[129249]: [1966-4] 2016-03-28 14:26:30: pid 129249: CONTEXT: while checking replication time lag
Mar 28 14:26:32 puppetserver pgpool[129249]: [1967-1] 2016-03-28 14:26:32: pid 129249: LOG: failed to connect to PostgreSQL server on "192.168.80.163:5432", getsockopt() detected error "No route to host"
Additional InformationWhat I expected is the pgpool will change over to other pgpool and postgreql will failover too。
TagsNo tags attached.

Activities

wangzhenbo

2016-03-28 16:54

reporter   ~0000731

When cannot connect the node,will continues to retry connectting the node。


root@puppetserver:/var/lib/postgresql/pgpool-II-3.4.4# grep "timed out. retrying..." -nR .
Binary file ./src/pgpool matches
./src/protocol/pool_connection_pool.c:628: errdetail("timed out. retrying...")));
Binary file ./src/protocol/pool_connection_pool.o matches
root@puppetserver:/var/lib/postgresql/pgpool-II-3.4.4# vim ./src/protocol/pool_connection_pool.c +628

wangzhenbo

2016-04-01 12:18

reporter   ~0000751

I resolved the problem.
Because I set the trust IP is BIG-IP,and actually in stream replication I use SMALL-IP.
when I plugs out the cable, the pgpool ping trust IP is OK, donnot think the node is NG.so nothing to do.

Sorry to trouble you.

Issue History

Date Modified Username Field Change
2016-03-28 15:31 wangzhenbo New Issue
2016-03-28 16:54 wangzhenbo Note Added: 0000731
2016-04-01 08:41 t-ishii Assigned To => Muhammad Usama
2016-04-01 08:41 t-ishii Status new => assigned
2016-04-01 12:18 wangzhenbo Note Added: 0000751
2016-05-06 16:45 t-ishii Status assigned => resolved