View Issue Details

IDProjectCategoryView StatusLast Update
0000175Pgpool-IIBugpublic2016-04-02 11:09
Reporternaren@publicrelay.comAssigned Tot-ishii 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionopen 
PlatformLinuxOSCentosOS Version6
Product Version 
Target VersionFixed in Version 
Summary0000175: Hibernate + Pgpool-II Connection Failure
DescriptionI am using pgpool 3.5 with hibernate 4.1.12 connecting to postgres 9.3 running in master-slave mode. I have turned load balancing on and that is when all the problems started. Everything works fine with the normal psql connection but not through hibernate.

Here are the messages collected from various logs:

Tomcat logs:

2016-03-17 18:43:23,856 [ajp-bio-8009-exec-5] DEBUG [] jdbc.JdbcTransaction - Could not toggle autocommit org.postgresql.util.PSQLException: This connection has been closed.
2016-03-17 18:43:23,857 [ajp-bio-8009-exec-5] DEBUG [] spi.SqlExceptionHelper - This connection has been closed. [n/a] org.postgresql.util.PSQLException: This connection has been closed.
2016-03-17 18:43:23,858 [ajp-bio-8009-exec-5] WARN [] spi.SqlExceptionHelper - SQL Error: 0, SQLState: 08003
2016-03-17 18:43:23,858 [ajp-bio-8009-exec-5] ERROR [] spi.SqlExceptionHelper - This connection has been closed.
2016-03-17 18:43:23,858 [ajp-bio-8009-exec-5] DEBUG [] internal.SessionImpl - Disconnecting session
2016-03-17 18:43:23,858 [ajp-bio-8009-exec-5] DEBUG [] internal.LogicalConnectionImpl - Releasing JDBC connection
2016-03-17 18:43:23,858 [ajp-bio-8009-exec-5] DEBUG [] spi.SqlExceptionHelper - Could not close connection [n/a]

popool logs:
2016-03-17 18:43:23: pid 1489: DETAIL: discard 1 packet from backend 1
2016-03-17 18:43:23: pid 1489: LOG: pool process query
2016-03-17 18:43:23: pid 1489: DETAIL: discard 2 packet from backend 1
2016-03-17 18:43:23: pid 1489: LOG: pool process query
2016-03-17 18:43:23: pid 1489: DETAIL: discard N packet from backend 1
2016-03-17 18:43:23: pid 1489: WARNING: packet kind of backend 1 ['C'] does not match with master/majority nodes packet kind ['1']
2016-03-17 18:43:23: pid 1489: FATAL: failed to read kind from backend
2016-03-17 18:43:23: pid 1489: DETAIL: kind mismatch among backends. Possible last query was: "COMMIT" kind details are: 0[1] 1[C]
2016-03-17 18:43:23: pid 1489: HINT: check data consistency among db nodes
2016-03-17 18:43:23: pid 1456: LOG: child process with pid: 1489 exits with status 512
2016-03-17 18:43:23: pid 1456: LOG: fork a new child process with pid: 1498
2016-03-17 18:54:57: pid 1456: LOG: received fast shutdown request
2016-03-17 18:54:57: pid 1511: LOG: stop request sent to pgpool. waiting for termination...
2016-03-17 18:54:57: pid 1456: LOG: shutdown request. closing listen socket


postgres logs on both Master and Slave:

postgresWARNING: there is already a transaction in progress
postgresWARNING: there is already a transaction in progress
postgresWARNING: there is already a transaction in progress

Following is the hibernate connection parameters I have:

DOCKER:ctomcat-run properties$ cat hibernate.properties
hibernate.datasource = dataSource

hibernate.jdbcdriver = org.postgresql.Driver
hibernate.connection.url = jdbc:postgresql://dbpgpool:9999/client
hibernate.connection.username = postgres
hibernate.connection.password = ******

hibernate.showsql = true
hibernate.formatsql = false
hibernate.sqlcomments = false
hibernate.use_sql_comments = false

hibernate.dialect = org.hibernate.dialect.PostgreSQLDialect
hibernate.hbm2ddl.auto = none

I have attached pgpool.conf

Looks like hibernate and pgpool are creating transactions within transactions.

So not sure, what configuration changes i need to make either in hibernate or pgpool. Any help will be greatly appreciated.
TagsNo tags attached.

Activities

naren@publicrelay.com

2016-03-18 23:11

reporter  

pgpool.conf (34,392 bytes)

naren@publicrelay.com

2016-03-29 03:20

reporter   ~0000735

Hey guys,

Any help on this will be huge to us, could you please share some ideas on how to tackle this issue ?

Thanks
Naren

t-ishii

2016-04-01 11:52

developer   ~0000749

It is possible it has been already fixed. On April 1st, pgpool-II 3.5.2 will be released. Can you please try it out?

naren@publicrelay.com

2016-04-01 23:16

reporter   ~0000752

Thanks a lot ishii for getting back, sure I will try it today and let you know how it goes.

Thanks again
Naren

naren@publicrelay.com

2016-04-02 08:12

reporter   ~0000753

3.5.0.2 fixed the problem, thank you very much !!!

-Naren

t-ishii

2016-04-02 11:08

developer   ~0000754

Great! The initial schedule was changed. We are going to release 3.5.1 on April 4. Just F.Y.I.

Issue History

Date Modified Username Field Change
2016-03-18 23:09 naren@publicrelay.com New Issue
2016-03-18 23:11 naren@publicrelay.com File Added: pgpool.conf
2016-03-29 03:20 naren@publicrelay.com Note Added: 0000735
2016-04-01 11:52 t-ishii Note Added: 0000749
2016-04-01 11:52 t-ishii Assigned To => t-ishii
2016-04-01 11:52 t-ishii Status new => feedback
2016-04-01 23:16 naren@publicrelay.com Note Added: 0000752
2016-04-01 23:16 naren@publicrelay.com Status feedback => assigned
2016-04-02 08:12 naren@publicrelay.com Note Added: 0000753
2016-04-02 11:08 t-ishii Note Added: 0000754
2016-04-02 11:09 t-ishii Status assigned => resolved