View Issue Details

IDProjectCategoryView StatusLast Update
0000011Pgpool-IIBugpublic2012-06-26 10:30
ReportergencerAssigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionopen 
PlatformLinuxOSCentOSOS Version5.8
Product Version 
Target VersionFixed in Version 
Summary0000011: pgpool-)II 3.1.2 does not see my pool_hba.conf file
DescriptionI have a valid pool_hba.conf file inside of the /etc/pgpool-II/ folder. I installed this application from directly the c++ codes but not RPM.

pgpool.conf loaded successfully but when it comes to read pool_hba.conf it shows me an error and says 127.0.0.1 is not allowed to connect to this server.
Steps To Reproduce1. Install it from c++ spources with ./configure and with pgsql folder argument for libq.
2. Copy sample confs to the /etc/pgpool-II.
3. Enable pool_hba feature
4. Connect from 127.0.0.1 and it says postgres user and 127.0.0.1 host is not defined in pool_hba.

---

I also try defining pool_hba file by using pgpool --c argument.
Additional Informationall files attached.
TagsNo tags attached.

Activities

gencer

2012-05-06 02:59

reporter  

pgpool-II.tar.gz (5,207 bytes)

anzai

2012-05-11 13:21

developer   ~0000023

Last edited: 2012-05-11 13:24

View 2 revisions

I'm wordering if you don't connect to pgpool AS the user "postgres".
I succeeded to connect with your pool_hba.conf.

--------------------------------------------------------------------------------
$ psql -p 9999 -h 127.0.0.1 -U postgres test
psql (9.1.0)
Type "help" for help.

test=# \q
$ psql -p 9999 -h 127.0.0.1 -U anzai test
psql: ERROR: no pool_hba.conf entry for host "127.0.0.1", user "anzai", database "test"
--------------------------------------------------------------------------------

Please try to execute "psql -p 9999 -h 127.0.0.1 -U postgres" to confirm, or replace the row as follows:

[ pool_hba.conf ]
| # "local" is for Unix domain socket connections only
| local all all trust
| # IPv4 local connections:
| host all postgres 127.0.0.1/32 trust
                      ^^^^^^^^
                      => all

Or pgpool doesn't read your pool_hba.conf.
Can you try "pgpool -a etc/pool_hba.conf" ?

gencer

2012-05-11 17:22

reporter   ~0000025

Last edited: 2012-05-11 17:58

View 6 revisions

@anzai, i stopped all working copies of pgpool. After that i did this:

pgpool -a /etc/pgpool-II/pool_hba.conf -f /etc/pgpool-II/pgpool.conf

And voala! It is worked! But, how can i tell pgpool that pool_hba.conf relies on /etc/pgpool-II/ folder? Do i have to do this arguments always?

----BTW, before i open this issue, i tried same thing but it didn't worked well but i know why. I forgot to terminate all working copies of pgpool. Because of that old settings are used.-----

anzai

2012-05-11 17:43

developer   ~0000026

I'm glad to hear that.

> Do i have to do this arguments always?

Yes.
If you don't add args about the files to the command "pgpool", pgpool tries to read files in the default path.

$ pgpool --help
(snip)
Common options:
  -a, --hba-file=HBA_CONFIG_FILE
                      Sets the path to the pool_hba.conf configuration file
                      (default: /etc/pool_hba.conf)
  -f, --config-file=CONFIG_FILE
                      Sets the path to the pgpool.conf configuration file
                      (default: /etc/pgpool.conf)
  -F, --pcp-file=PCP_CONFIG_FILE
                      Sets the path to the pcp.conf configuration file
                      (default: /etc/pcp.conf)
(snip)

FYI, you don't have to do that with pgpoolAdmin which can store these args in its config file.

gencer

2012-05-11 17:57

reporter   ~0000027

Last edited: 2012-05-11 17:58

View 2 revisions

Thanks for the info. I updated the service file to handle -a argument. Issue is resolved.

Issue History

Date Modified Username Field Change
2012-05-06 02:59 gencer New Issue
2012-05-06 02:59 gencer File Added: pgpool-II.tar.gz
2012-05-11 13:21 anzai Note Added: 0000023
2012-05-11 13:24 anzai Note Edited: 0000023 View Revisions
2012-05-11 17:22 gencer Note Added: 0000025
2012-05-11 17:23 gencer Note Edited: 0000025 View Revisions
2012-05-11 17:29 gencer Note Edited: 0000025 View Revisions
2012-05-11 17:29 gencer Note Edited: 0000025 View Revisions
2012-05-11 17:30 gencer Note Edited: 0000025 View Revisions
2012-05-11 17:43 anzai Note Added: 0000026
2012-05-11 17:57 gencer Note Added: 0000027
2012-05-11 17:58 gencer Note Edited: 0000025 View Revisions
2012-05-11 17:58 gencer Note Edited: 0000027 View Revisions
2012-06-26 10:30 t-ishii Status new => closed