View Issue Details

IDProjectCategoryView StatusLast Update
0000280pgpool-IIBugpublic2017-01-27 06:04
Reportersupp_kAssigned ToMuhammad Usama 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86 64OSCentOSOS Version7.3.1611
Product Version3.6.1 
Target VersionFixed in Version 
Summary0000280: stack smashing detected
Descriptionpgpool start fails with error:

[root@OAA-0dd3747a339a ~]# service pgpool start

Redirecting to /bin/systemctl start pgpool.service
[root@OAA-0dd3747a339a ~]# service pgpool status
Redirecting to /bin/systemctl status pgpool.service
● pgpool.service - pgpool-II
   Loaded: loaded (/usr/lib/systemd/system/pgpool.service; disabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/pgpool.service.d
           └─pgpool.conf
   Active: failed (Result: signal) since Mon 2017-01-16 22:04:36 MSK; 2s ago
  Process: 662 ExecStart=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $OPTS (code=killed, signal=SEGV)
  Process: 636 ExecStartPre=/etc/pgpool-II/pool_start_check.sh (code=exited, status=0/SUCCESS)
 Main PID: 662 (code=killed, signal=SEGV)

Jan 16 21:53:44 OAA-0dd3747a339a.aqa.int.zone pgpool[2563]: [10-1] LOG: watchdog node state changed from [JOINING] to [INITIALIZING]
Jan 16 21:53:44 OAA-0dd3747a339a.aqa.int.zone pgpool[2563]: [10-2] LOCATION: watchdog.c:5740
Jan 16 21:53:48 OAA-0dd3747a339a.aqa.int.zone pgpool[2631]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 16 21:54:05 OAA-0dd3747a339a.aqa.int.zone pgpool[2699]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 16 21:54:24 OAA-0dd3747a339a.aqa.int.zone pgpool[2776]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 16 21:55:50 OAA-0dd3747a339a.aqa.int.zone pgpool[2872]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 16 21:57:26 OAA-0dd3747a339a.aqa.int.zone pgpool[2954]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 16 21:58:30 OAA-0dd3747a339a.aqa.int.zone pgpool[3027]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 16 22:04:36 OAA-0dd3747a339a.aqa.int.zone pgpool[662]: *** stack smashing detected ***: /usr/bin/pgpool terminated
Additional Informationpgpool version: pgpool-II version 3.6.1 (subaruboshi)

Fails installation available at: http://www.pgpool.net/yum/rpms/3.6/redhat/rhel-7-x86_64/pgpool-II-pg96-3.6.1-1pgdg.rhel7.x86_64.rpm
TagsNo tags attached.

Activities

supp_k

2017-01-17 18:34

reporter   ~0001293

The case is reproduced if the pgpool configuration has the values like:

delegate_IP = '192.168.110.34'
if_cmd_path = '/etc/pgpool-II'
if_up_cmd = 'vip_up.sh'
if_down_cmd = 'vip_down.sh'

The 'if_up_cmd' and 'if_down_cmd' commands have no placeholders for the VIP.

supp_k

2017-01-25 19:24

reporter   ~0001297

Hi Pgpool Developers,

Can you please clarify the information on the status of this issue?

Thank you!

Muhammad Usama

2017-01-25 21:43

developer   ~0001298

Hi

I am not able to reproduce this issue. Can you produce it reliably or does it happen randomly?
Can you also share the Pgpool.conf file and the core dump if possible.

Thanks

supp_k

2017-01-25 22:25

reporter   ~0001299

Hi,
the issue is easily reproduced with command: # pgpool -n -f pgpool.conf

several core dumps together with full configuration files are attached.



Environment:
1) Version info: # pgpool --version => pgpool-II version 3.6.1 (subaruboshi)

2) # uname --all
Linux OAA-72c02c29743e.aqa.int.zone 3.10.0-042stab117.16 0000001 SMP Fri Sep 9
21:57:19 MSK 2016 x86_64 x86_64 x86_64 GNU/Linux

3) # cat /etc/*rele*

CentOS Linux release 7.3.1611 (Core)
Derived from Red Hat Enterprise Linux 7.3 (Source)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

CentOS Linux release 7.3.1611 (Core)
CentOS Linux release 7.3.1611 (Core)
cpe:/o:centos:centos:7

pgpool_crash.tar.gz (2,020,909 bytes)

supp_k

2017-01-25 22:28

reporter   ~0001300

Also the /var/log/messages file logs:

Jan 25 16:27:14 OAA-72c02c29743e pgpool: *** stack smashing detected ***: /usr/bin/pgpool terminated
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [108-1] WARNING: checking setuid bit of if_up_cmd
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [108-2] DETAIL: ifup[/etc/pgpool-II/vip_up.sh] doesn't have setuid bit
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [108-3] LOCATION: wd_utils.c:76
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [109-1] WARNING: checking setuid bit of if_down_cmd
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [109-2] DETAIL: ifdown[/etc/pgpool-II/vip_down.sh] doesn't have setuid bit
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [109-3] LOCATION: wd_utils.c:85
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [110-1] WARNING: checking setuid bit of arping command
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [110-2] DETAIL: arping[/usr/sbin/arping] doesn't have setuid bit
Jan 25 16:27:14 OAA-72c02c29743e pgpool[2073]: [110-3] LOCATION: wd_utils.c:95

supp_k

2017-01-25 23:34

reporter   ~0001301

Whether the provided artifacts provide enough information to resolve the problem?

Muhammad Usama

2017-01-27 06:04

developer   ~0001302

Thanks for providing all core dump and all configurations. Using those I was able to locate the problem and have pushed the fix in all relevant branches.

https://git.postgresql.org/gitweb/?p=pgpool2.git;a=commitdiff;h=751248263036417b99d2820d8d6d67db9829cff4

Issue History

Date Modified Username Field Change
2017-01-17 04:09 supp_k New Issue
2017-01-17 18:34 supp_k Note Added: 0001293
2017-01-25 19:24 supp_k Note Added: 0001297
2017-01-25 21:43 Muhammad Usama Note Added: 0001298
2017-01-25 22:25 supp_k File Added: pgpool_crash.tar.gz
2017-01-25 22:25 supp_k Note Added: 0001299
2017-01-25 22:28 supp_k Note Added: 0001300
2017-01-25 23:34 supp_k Note Added: 0001301
2017-01-27 06:04 Muhammad Usama Assigned To => Muhammad Usama
2017-01-27 06:04 Muhammad Usama Status new => resolved
2017-01-27 06:04 Muhammad Usama Resolution open => fixed
2017-01-27 06:04 Muhammad Usama Note Added: 0001302