[pgpool-hackers: 2635] Some problems in Makefile.am

Tomoaki Sato sato at sraoss.co.jp
Tue Dec 5 12:58:07 JST 2017


I'm building Pgpool-II 3.7 on CentOS 7.2. I found some problems in

First, when I run autoreconf, I get the following warnings about

  $ autoreconf
  doc.ja/src/sgml/Makefile.am:11: warning: ':='-style assignments are not portable
  doc.ja/src/sgml/Makefile.am:11: warning: wildcard $(srcdir: non-POSIX variable name
  doc.ja/src/sgml/Makefile.am:11: (probably a GNU make extension)

If you don't need to follow the GNU Standards, these warnings can be
prevented with the foreign option.

Then, when I run make dist clean, I get the following error:

  $ make distclean
  make[2]: Entering directory `/home/tom-sato/vcs/pgpool2.git/src'
  Makefile:879: utils/.deps/getopt_long.Po: No such file or directory
  Makefile:880: utils/.deps/json.Po: No such file or directory
  Makefile:881: utils/.deps/json_writer.Po: No such file or directory
  make[2]: *** No rule to make target `utils/mmgr/.deps/mcxt.Po'.  Stop.
  make[2]: Leaving directory `/home/tom-sato/vcs/pgpool2.git/src'
  make[1]: *** [distclean-recursive] Error 1
  make[1]: Leaving directory `/home/tom-sato/vcs/pgpool2.git/src'
  make: *** [distclean-recursive] Error 1

This error can be prevented with the no-dependencies option.

However, even if make dist clean completes successfully, some files
will remain.

  $ make && make -C doc && make -C doc.ja
  $ make distclean
  $ git status
  # Untracked files:
  #   (use "git add <file>..." to include in what will be committed)
  #       doc.ja/src/sgml/HTML.index
  #       doc.ja/src/sgml/bookindex.sgml
  #       doc.ja/src/sgml/man-stamp
  #       doc.ja/src/sgml/man1/
  #       doc.ja/src/sgml/man3/
  #       doc.ja/src/sgml/pgpool.xml
  #       doc/src/sgml/HTML.index
  #       doc/src/sgml/bookindex.sgml
  #       doc/src/sgml/man-stamp
  #       doc/src/sgml/man1/
  #       doc/src/sgml/man3/
  #       doc/src/sgml/pgpool.xml
  #       src/libs/pcp/json.c
  #       src/libs/pcp/md5.c
  #       src/libs/pcp/pcp_stream.c
  #       src/tools/pgmd5/fe_memutils.c
  #       src/tools/pgmd5/md5.c
  #       src/tools/pgmd5/pool_config.l
  #       src/tools/pgmd5/pool_config_variables.c
  #       src/tools/pgmd5/pool_globals.c
  #       src/tools/pgmd5/pool_passwd.c
  #       src/tools/pgmd5/pool_signal.c
  #       src/tools/pgmd5/regex_array.c
  #       src/tools/pgmd5/strlcpy.c
  #       src/tools/pgpool_setup
  #       src/tools/watchdog_setup

I fixed Makefile.am to delete files in the clean-local target or add
files to the CLEANFILES variable.

Finally, when I run make docs, I get the following error:

  $ make docs
  make -C doc doc.ja all
  make[1]: Entering directory `/home/tom-sato/vcs/pgpool2.git/doc'
  make[1]: *** No rule to make target `doc.ja'.  Stop.
  make[1]: Leaving directory `/home/tom-sato/vcs/pgpool2.git/doc'
  make: *** [docs] Error 2

I fixed Makefile.am as follows:

      $(MAKE) -C doc all && $(MAKE) -C doc.ja all

I attached a patch including the above fixes.


Tomoaki Sato <sato ¡÷ sraoss.co.jp>
SRA OSS, Inc. Japan

-------------- next part --------------
¥Õ¥¡¥¤¥ë̾: pgpool2-master-e9e6414-fix-makefile.patch
·¿:         application/octet-stream
¥µ¥¤¥º:     4159 ¥Ð¥¤¥È
ÀâÌÀ:       ̵¤·
URL:        <http://www.sraoss.jp/pipermail/pgpool-hackers/attachments/20171205/5d355e3f/attachment.obj>

More information about the pgpool-hackers mailing list