[pgpool-general: 7702] Re: PGPool-II 4.2.3 on CentOS 7.9: PCP Commands are ignoring .pcppass file

Francesco Mazzi fmazzi at comune.genova.it
Fri Sep 10 20:52:37 JST 2021

Hello Luca, .pcppass should be in the home directory of the user you invoke in the command, in your case pgpool user's home. 
Moreover, instead of you should put localhost or hostname. 

Da: "Luca Maranzano" <liuk001 at gmail.com> 
A: "pgpool-general" <pgpool-general at pgpool.net> 
Inviato: Venerdì, 10 settembre 2021 13:22:48 
Oggetto: [pgpool-general: 7701] PGPool-II 4.2.3 on CentOS 7.9: PCP Commands are ignoring .pcppass file 

Hi all, 

subject says all, I'm getting crazy trying to understand why pcp commands are completely ignoring .pcppass file. 

I'm sure the file is correct, I've also tried to use strace and from the output there is no attempt to open $HOME/.pcppass file. 

I've tried with user root and user postgres: 

# ls -l /root/.pcppass /var/lib/pgsql/.pcppass 
-rw------- 1 root root 44 Sep 10 13:06 /root/.pcppass 
-rw------- 1 postgres postgres 83 Jul 17 09:42 /var/lib/pgsql/.pcppass 

The command is: 

pcp_watchdog_info -h -p 9898 -U pgpool 

The file contains: 

What am I doing wrong? 

Thanks in advance 

Click [ https://www.mailcontrol.com/sr/K3UUO6qA3d3GX2PQPOmvUtiZD_0EqjaRnb9QQDAKWpPk5yU1wVmlulTW6IGbcKO-EJYWkiIbcMmJRcENOpaP7A== | here ] to report this email as spam. 
pgpool-general mailing list 
pgpool-general at pgpool.net 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.pgpool.net/pipermail/pgpool-general/attachments/20210910/3d7e7a38/attachment.htm>

More information about the pgpool-general mailing list