[pgpool-general: 6269] pgpool does not reuse connections

Andrey Zhidenkov andrey.zhidenkov at gmail.com
Fri Nov 9 20:05:41 JST 2018

We have a problem at one of our environments with pgpool. It does not
use connection pool for some reason. Application written on golang (we
use gorm which uses package https://golang.org/pkg/database/sql/)
opens connections to pgpool and executes queries. Application executes
every transaction in a separate connection. In postgresql logs I see
that pgpool constantly connects and disconnects from postgres like as
if connection pool is not used. I tried to reproduce this situation
with pgbench (option --connect) but everything is OK with it. pgpool
works with pgbench as expected - it reuses all connections and doesn't
create a new one for each transaction.

num_init_children = 100, max_pool =4. max_connections in postgres = 1000.

We tried pgpool versions 3.3.4 and 3.7.5.

Any ideas?

With best regards, Andrey Zhidenkov

More information about the pgpool-general mailing list