[pgpool-general: 6070] primary suddenly is down only in pgpool

Mariel Cherkassky mariel.cherkassky at gmail.com
Sun May 6 18:42:24 JST 2018

I have 3 postgres servers (one primary + 2 standbys) that have replciation
configured with repmgr:
pg1 - standby
pg2 - primary
pg3 - standby

I have also 2 pgpool servers(v 3.7.2 and on each one there is one pool
instance. There isnt any watchdog, instead I have a vip address that
directs the requests to the available pgpool instance. I configured my own
metrics that check the status of the database nodes via the pcp interface.

Today at 11:25 suddenly I got an alert that both my pgpools saw that the
primary node is down (via pcp). I connected and checked and indeed the
primary was down :
[postgres at pool2 log]$ pcp_node_info -h localhost -U postgres -p 9898 1 -w
pg2 5432 2 0.333333 down standby

I checked it in both pools and the same result. I immediatly attached them
and it worked. I wanted to understand why it happened but I dont see any
error in the logs. I attach the logs of both my pools. Can you help me
identify the problem ?

Thanks ,Mariel.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20180506/2afb1ca0/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pgpool.log.Sunday_node1
Type: application/octet-stream
Size: 4193217 bytes
Desc: not available
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20180506/2afb1ca0/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pgpool.log.Sunday_node2
Type: application/octet-stream
Size: 116012 bytes
Desc: not available
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20180506/2afb1ca0/attachment-0003.obj>

More information about the pgpool-general mailing list