[pgpool-general: 5490] Re: Pgpool silently failing

Tatsuo Ishii ishii at sraoss.co.jp
Thu May 18 08:28:37 JST 2017

> Hi! I've been trying to deploy a postgresql cluster in production during
> maintenance windows for a few days now. But I seem to run into an issue
> with pgpool.
> The pgpool sits on it's own instance infront of 4 x c3.2xlarge instance
> where the actual cluster is housed. The cluster is managed with repmgr. All
> servers are running FreeBSD 11.0 fully patched. I also tried pgpool on
> debian 8.8 with the same result. All of these servers are running on AWS in
> us-east-1. There is an extra instance which I am trying to migrate away
> from - the last one in the attached config. Plan was to setup the cluster,
> clone from current master and then do a switchover and lastly shut down old
> master and detach it from pgpool.
> The pgpool has no issue finding the backends and marking them as healthy.
> However, when I am trying to add more than one of our webservers to it (RoR
> based API webserver) it silently fails, or so it seems atleast.

So one of the web servers running RoR cannot connect to Pgpool-II?

> I ran
> pgpool in foreground and did not note any errors at all. Nor were there any
> errors in PostgreSQL servers, except for the occassional slow query.
> I could during these attempts to deploy connect to the servers indivudally
> from the pgpool instance and execute queries. So I am fairly certain there
> were no connectivity issues - no dropped packets were observed either.
> I am hoping this is a configuration issue on my end. If not I would like to
> request assistance in how I could debug this.

One of the starters is, turn on debug mode on Pgpool-II.

> I am attaching the config of pgpool in this mail. Please let me know if you
> see something obviously incorrect.

So far I see no problems.

Best regards,
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php

More information about the pgpool-general mailing list