[pgpool-general: 5643] Connections stuck in CLOSE_WAIT in pgpool

Ziyun Audrey Wang ziyun.wang at ericsson.com
Thu Jul 27 04:54:09 JST 2017


We had pgpool pgpool-II-pg94-3.5.3-1pgdg.rhel6.x86_64.rpm<http://www.pgpool.net/yum/rpms/3.5/redhat/rhel-6-x86_64/pgpool-II-pg94-3.5.3-1pgdg.rhel6.x86_64.rpm>, it worked fine, no problem.

Recently, we upgrade our pgpool and postgresql to 96
With pgpool pgpool-II-pg96-3.6.2-1pgdg.rhel6.x86_64.rpm<http://www.pgpool.net/yum/rpms/3.6/redhat/rhel-6-x86_64/pgpool-II-pg96-3.6.2-1pgdg.rhel6.x86_64.rpm>, we got Connections stuck in CLOSE_WAIT in pgpool
And the pgpool was hung, not accept any connection.
Restart the pgpool will resolve the problem but then the it will be stuck again after a while, as soon as we rollback to version pg94-3.5.3, all worked fine.

We need to move forward with the latest release of postgresql and pgpool, but as soon as we change the version newer than pg94-3.5.3, we got the CLOSE_WAIT issue.
We are wondering what's the difference between this two version,, is there anything we misconfigured?

Thanks a lot for the help!

Best Regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20170726/26e4fba6/attachment.html>

More information about the pgpool-general mailing list