[pgpool-general: 5337] Re: unrecognized configuration parameter "pool_status"

Yugandha Deshpande yugandha at us.ibm.com
Fri Feb 17 12:50:15 JST 2017


	Yes Tatsuo, I want to run regression tests. I am using RHEL-7.3.
	As you suggested I ran "bash -x /path/to/pgpool_setup", I have
attached the log here.

(See attached file: pgpool_setup_debug_log.txt)

Thanks & Regards,

From:	Tatsuo Ishii <ishii at sraoss.co.jp>
To:	lazaro3487 at gmail.com
Cc:	Yugandha Deshpande/Austin/Contr/IBM at IBMUS,
            pgpool-general at pgpool.net
Date:	02/17/2017 07:16 AM
Subject:	Re: [pgpool-general: 5335] Re: unrecognized configuration
            parameter "pool_status"


I think Yugandha wanted to run the regression test (the test runs
pgpool_setup inside), not want to use pgpool_set for production


Can you run pgpool_setup by "bash -x /path/to/pgpool_setup" to take
debugging output? Also I would like to know what OS/distribution you
are using.
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php

From: "Lazaro Garcia" <lazaro3487 at gmail.com>
Subject: [pgpool-general: 5335] Re: unrecognized configuration parameter
Date: Thu, 16 Feb 2017 11:12:23 +0100
Message-ID: <001101d2883d$2c795f20$856c1d60$@gmail.com>

> pool_status is an invalid configuration parameter for pgpool. I never
> pgpool_setup, but the documentation says that this command is not
> for production enviroment. For this reason I always create all by hand.
> I recomend you create your postgres cluster, then install and configure
> pgpool using the samples configuration files proposed by pgpool
> Regards.
> De: pgpool-general-bounces at pgpool.net
> [mailto:pgpool-general-bounces at pgpool.net] En nombre de Yugandha
> Enviado el: jueves, 16 de febrero de 2017 10:53 a. m.
> Para: pgpool-general at pgpool.net
> Asunto: [pgpool-general: 5334] unrecognized configuration parameter
> "pool_status"
> Hi,
> I am trying to build pgpool2.
> OS: Linux
> I could build it successfully. But when I run tests, it fails. Also if I
> pgpool_setup command it fails with following log:
> LOG:
> ERROR: unrecognized configuration parameter "pool_status"
> ERROR: unrecognized configuration parameter "pool_status"
> ERROR: unrecognized configuration parameter "pool_status"
> ERROR: unrecognized configuration parameter "pool_nodes"
> recovery node 1...ERROR: connection to host "localhost" failed with error
> "Connection refused"
> done.
> creating follow master script
> ERROR: unrecognized configuration parameter "pool_nodes"
> shutdown all
> pgpool-II setting for streaming replication mode is done.
> To start the whole system, use /root/yugandha/pgpool2/o/o/startall.
> To shutdown the whole system, use /root/yugandha/pgpool2/o/o/shutdownall.
> pcp command user name is "test", password is "test".
> Each PostgreSQL, pgpool-II and pcp port is as follows:
> #1 port is 11002
> #2 port is 11003
> pgpool port is 5432
> pcp port is 5433
> The info above is in README.port.
> Has anyone seen similar issue, if so please suggest if I have missed any
> step or configuration.
> Thanks & Regards,
> Yugandha.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20170217/200a6b97/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: graycol.gif
Type: image/gif
Size: 105 bytes
Desc: not available
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20170217/200a6b97/attachment-0001.gif>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: pgpool_setup_debug_log.txt
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20170217/200a6b97/attachment-0001.txt>

More information about the pgpool-general mailing list