[pgpool-general: 5418] Re: pgpooladmin version issue

Bo Peng pengbo at sraoss.co.jp
Fri Apr 7 15:27:52 JST 2017


On Mon, 27 Feb 2017 17:36:10 -0500
Justin Edmands <shockwavecs at gmail.com> wrote:

> Hey pgpoolers,
> I have come across an issue that likely requires me to upgrade pgpool-II-93
> version 3.4 to 3.5.
>  - After upgrading to 3.5, pgpoolAdmin status pages all show "pcp_node_info
> command error occurred."

>From Pgpool-II 3.5 the .pcppass file is required when using pgpoolAdmin.
Could you try the following steps?


  -bash-4.2$ pwd
  -bash-4.2$ cat .pcppass
  -bash-4.2$ chmod 600 .pcppass

>  - I suppose I need to upgrade pgpooladmin to show version 3.5 as the
> dropdown menu in the "pgpoolAdmin Setting" (only showed up to 3.4)

This is fixed in


> - Attempting to upgrade to pgpooladmin 3.5 states that I need to upgrade
> pgpool-II-93 to pg-pool-96 in order for pgpooladmin 3.5 to install.

Pgpool-II works with  pg-pool-96.
But it is recommended that you use the latest version of pgpoolAdmin 3.6.x.

> Anyways...I have postgres 9.3 data nodes. Will pgpool-II-96 have an issue
> with postgres 9.3 data nodes?

Bo Peng <pengbo at sraoss.co.jp>
SRA OSS, Inc. Japan

More information about the pgpool-general mailing list