[pgpool-general: 4675] Re: Problem shutting down interfaces

Ricardo Larrañaga ricardo.larranaga at gmail.com
Wed May 11 03:06:31 JST 2016

Hi guys:
I have been working on this a little bit, and i encounter this problem
(running pgpool 3.5.2 on a 2 node cluster with streaming replication, if i
shut down the interface of the slave, pgpool on the master hangs the
connections). And i realize that the problem only happens when i shut down
the interface. If i either shut down the processes or use the firewall to
block backend communication, pgpool reacts properly.

Does anyone have experience with this or have a 2 node cluster with
streaming replication to test it. I am trying to identify what makes the
setup hang, since shutting down the interface is the best way i have to
simulate a node crash. When i shut down the interface, both postgres and
pgpool loose connection, but this is a valid scenario that could happen in
real life (when the whole server crashes).
Thanks a lot.

On Thu, May 5, 2016 at 4:55 PM, Ricardo Larrañaga <
ricardo.larranaga at gmail.com> wrote:

> Hello guys:
> I am running pgpool 3.5.2 in a 2 node cluster with postgresql-9.5 in
> master-slave and streaming replication mode.
> I have been testing failover and failback for a while. While doing
> failover by shutting down the processes, everything looks fine.
> The one test that is failing is when i shutdown the interface of one node.
> Right now i am shutting down the interface of the slave node (both pgool
> slave and postgresql slave).
> The problem i am running into is that after doing this, all connections to
> my database (through pgpool) hang. i am testing it with psql, and psql just
> hangs and does not give me an output. When i bring the interface of the
> slave back up, and try to connect to psql again, it looks like pgpool never
> marked the postgresql node as disconnected.
> I tried both with and without health check, and also tried with different
> values of health_check_timeout. my connect timeout value is default (10
> seconds).
> Any one has encountered this issue? I just dont see pgpool attempting to
> do any failover. Pgpool is still running though, i can see the logs still
> comming. I just never see an error.
> I am NOT using interface monitoring, and i would prefer not to use it.
> Any pointers on how could i troubleshoot this?
> Thanks.
> Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20160510/2488e9f9/attachment.html>

More information about the pgpool-general mailing list