[pgpool-general: 4418] Re: [Problem] libpq is not installed or libpq is old

Tatsuo Ishii ishii at postgresql.org
Tue Feb 9 20:52:58 JST 2016

> I have PostgreSQL 9.4 installed on a SUSE-Linux-Enterprise-Server-11-SP4
> 11.4.4-1.109 and now I am trying to configure pgpool II, I have downloaded
> pgpool-II-3.5.0.tar.gz. When I run ./configure this message, according to
> the tutorial I tried this:
>  find / -type f -iname "*libpq*"
> /usr/lib64/libpq.so.5.7
> --
> ./configure --with-pgsql-libdir=/usr/lib64/libpq.so.5.7
> ./configure --with-pgsql-libdir=/usr/lib64/
> ./configure --with-pgsql=/usr/lib64/
> export LD_LIBRARY_PATH=/usr/lib64/
> ./configure
> I am still viewing this message. Any tip?
> Thanks in advance.

I am not familiar with SUSE packaging, but I guess you need libpq
development package (header files) be installed.

Also I wonder if you have pg_config command be installed and it's in
your command search path. If yes, you should be able to run
./configure without options to specify libpq location. If not, please

./configure --with-pgsql-libdir=/usr/lib64 --with-pgsql-includedir=path-to-the-dir-where-libpq-fe.h-exists

Best regards,
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php

More information about the pgpool-general mailing list