[pgpool-general: 3431] Re: Fwd: Upgrading PostgreSQL to V9.4.0

Tatsuo Ishii ishii at postgresql.org
Wed Jan 21 08:09:53 JST 2015

My guess is, pg_upgrade found pgpool_regclass in pg_proc and looked
for its .so file and failed. When you start the old server, do you
see the function by using \df command of psql?

Best regards,
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php

> Hi all,
> I've hit a snag while trying to upgrade my PostgreSQL primary server
> from V9.3.3 to V9.4.0 related to PGPool-II. I had turned off both
> pgpool and the old postgresql server and tried to run pg_upgrade, but
> it failed with a 'Could not load library
> "$libdir/pgpool-regclass"'. (BTW, if you're running streaming
> replication, you either need to leave a standby running for
> pg_upgrade, or reconfigure your primary to be a standalone.) I had
> assumed that I was going to need to reinstall pgpool, and was going to
> take the opportunity to upgrade that to the latest version as well,
> but how do I get this extension out of here for now? I've tried
> restarting the original database and entering "drop extension
> pgpool-regclass", but that says no such extension, and while I'm not
> exactly certain where the extensions are recorded, I didn't see this
> listed in pg_extensions either. Nevertheless, pg_upgrade keeps
> throwing an error in the loadable_libraries.txt file when run.
> Help?,
> Jay
> _______________________________________________
> pgpool-general mailing list
> pgpool-general at pgpool.net
> http://www.pgpool.net/mailman/listinfo/pgpool-general

More information about the pgpool-general mailing list