[pgpool-general: 2516] pgpoolAdmin-3.3.0 blank screen on status.php page

Samuel P Howard sam.howard at gmail.com
Sat Feb 1 05:49:10 JST 2014


Trying to get a new install going and keep running into the same problem.

I install a fresh Ubuntu 12.04 server, apache2 + php5, pgpool 3.3.1 from source, build and install, copy pgpoolAdmin-3.3.0 into apache's webroot, fire it up and I get the install screen as expected.

All the files in the webroot are owned by www-data, the install completes, I can get past the login.php page, and it takes me to a blank status.php page.

No pgpool processes are running either (doesn't look like it tried to start anything).

I can find no logs of interest, just the web server returning a 500 code.

I've dug though the PHP and have just gotten frustrated.

I've tried apache2 + libphp, nginx + fastcgi/php … lots of combinations, all give the same result.

Same configuration works with pgpoolAdmin 3.0.2 (at least past the initial status.php screen).

Also, is there a good tutorial for setting up a pgpool2 configuration with 2-3 EXTERNAL postgres servers?  Most of the examples I've found all have Postgres on the same server with different ports … I think I'm missing stuff because it's not working as I expect.


More information about the pgpool-general mailing list