[pgpool-general: 2129] Re: pgpool-HA resource agent monitor not running

Mistina Michal Michal.Mistina at virte.sk
Thu Sep 12 22:01:23 JST 2013

Hi Haruka.
Thanks for edited pgpool resource agent. It worked and solved other issues
with migrating resources. Thank you very much.
I should have mentioned that the issue I wrote about occurred only while
migrating. If I started resource manually on one node there were no
monitoring errors.

Best regards,
Michal Mistina
-----Original Message-----
From: pgpool-general-bounces at pgpool.net
[mailto:pgpool-general-bounces at pgpool.net] On Behalf Of TAKATSUKA Haruka
Sent: Thursday, September 12, 2013 5:25 AM
To: pgpool-general at pgpool.net
Subject: [pgpool-general: 2125] Re: pgpool-HA resource agent monitor not


Perhaps this is pgpool-ha's defect.
Current pgpool-ha script does not wait thet pgpool become ready at start

Please try the attached file. 

On Wed, 11 Sep 2013 13:42:44 +0000
Mistina Michal <Michal.Mistina at virte.sk> wrote:

> Hi to everybody.
> I'm running pgpool on the top of 2-node pacemaker cluster. There are 
> couple more services running on each server.
> After I migrate from one node to another I am experiencing a failure 
> of monitoring action on the pgpool resource agent. However pgpool 
> service is running.
> It looks like this:
> [root at tstcaps01 ~]# crm_mon -1
> Failed actions:
>     pg_pool_monitor_120000 (node=tstcaps01, call=30, rc=7,
> not running
> Configuration snippet:
> [root at tstcaps01 ~]# crm configure show primitive pg_pool 
> ocf:heartbeat:pgpool \
>         params pgpoolconf="/etc/pgpool-II/pgpool.conf"
> pcpconf="/etc/pgpool-II/pcp.conf" hbaconf="/etc/pgpool-II/pool_hba.conf"
> logfile="/var/log/pgpool/pgpool.log" pgpooluser="postgres"
> checkstring="/var/run/pgpool/pgpool.pid" pgpoolcmd="/usr/bin/pgpool"
> psqlcmd="/usr/pgsql-9.2/bin/psql" pcpnccmd="/usr/bin/pcp_node_count" \
>         op monitor interval="120" timeout="130" \
>         op start interval="0" timeout="60" \
>         op stop interval="0" timeout="60" \
>         meta is-managed="true"
> There are no errors in the pgpool.log.
> I'm using pgpool-ha 2.1, pacemaker 1.1.7-6.el6, corosync 1.4.1-7.el6.

TAKATSUKA Haruka harukat at sraoss.co.jp  SRA OSS, Inc  http://www.sraoss.co.jp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3076 bytes
Desc: not available
URL: <http://www.sraoss.jp/pipermail/pgpool-general/attachments/20130912/5236baf9/attachment.p7s>

More information about the pgpool-general mailing list