[pgpool-general: 1808] Re: SOLVED Replication and JDBC, problem when writting data

Stelios Limnaios stelios.limnaios at mekon.com
Thu May 30 21:07:54 JST 2013

Many thanks Tatsuo, it looks much better now!


-----Original Message-----
From: Tatsuo Ishii [mailto:ishii at postgresql.org] 
Sent: 29 May 2013 23:42
To: Stelios Limnaios
Cc: pgpool-general at pgpool.net
Subject: Re: [pgpool-general: 1789] Replication and JDBC, problem when writting data

> Hi all,
> I'm kindly asking for some help.
> We have a PGPool setup with 2 Postgres.
> We enabled Master/Slave stream replication + Online recovery.
> We also have a Java (j2ee) application that connects via JDBC  to PGPool.
> All these work fine and our application reads and writes data with no problem.
> Now, we are interested on moving from Master/Slave to Replication.
> In the above setup we tried to disable Master/Slave and enable Replication.
> Our Java application can successfully read data from PGPool, but something goes wrong when it tries to write data.
> Something hangs in PGPool and it doesn't allow the process to complete.
> Java doesn't log any exceptions, neither Postgres logs (on both backends).
> In PGPool log we don't see something with error on it, but there a few strange messages.
> For this, I have attached PGPool log, maybe someone could understand what goes wrong?
> Also, when this happens we cannot stop PGPool, until we kill some processes manually:
> If we run
> ps aux | grep psql
> we see many processes running, but we distinguish these
> pgpool: postgres pgv2a localhost.localdomain(36791) idle
> pgpool: postgres pgv2a localhost.localdomain(36781) idle
> pgpool: postgres pgv2a localhost.localdomain(36883) idle
> pgpool: postgres pgv2a localhost.localdomain(36536) idle
> pgpool: postgres pgv2a localhost.localdomain(36685) idle in 
> transaction
> pgpool: postgres pgv2a localhost.localdomain(36897) idle
> pgpool: postgres pgv2a localhost.localdomain(38356) idle that we have 
> to kill manually.
> I've also attached pgpool.conf.
> We're using pgpool 3.2.3, postgres 9.1, pgpooladmin 3.2.0 and the server is Centos 6.2 (SELinux disabled).
> Anyone could explain why Master/Slave works fine, but Replication not?
> Any help is much appreciated.

No idea at this point. However recently we had similar problem and fixed it in 3.2-stable tree. If possible, could you try the 3.2-stable from git repository. You can grab the tar ball from:


The fix was this:
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese: http://www.sraoss.co.jp

More information about the pgpool-general mailing list