View Issue Details

IDProjectCategoryView StatusLast Update
0000064Pgpool-IIBugpublic2013-07-19 10:35
ReporterpatrickrodiesAssigned Tot-ishii 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionopen 
PlatformBSDOSFreebsdOS Version9.1
Product Version 
Target VersionFixed in Version 
Summary0000064: Using
DescriptionUsing simple php (same with Perl) script such as:
 $dbconn = pg_connect("host=10.177.194.133 port=9999 dbname=playnw_log user=pgsql password=lmZrW1KmJB");

        $result = pg_prepare($dbconn, "my_query", 'SELECT sum(views) FROM logs_uk');

        print_r($result);
        $result = pg_execute($dbconn, "my_query");
        print_r($result);
will return an error on backend database receiving request

db-09 postgres[17206]: [3-1] ERROR: function "pgpool_regclass(cstring)" does not exist
db-09 postgres[17206]: [3-2] STATEMENT: SELECT count(*) FROM pg_catalog.pg_proc AS p WHERE p.proname = 'pgpool_regclass' AND has_function_privilege('pgsql', 'pgpool_regclass(cstring)', 'execute')

Thanks
Additional Informationpgpool-II Version 3.2
Postgresql Version 9.2

Setup fpr pgpool
Replication Mode Off
Master Slave mode On / stream
Parallel Mode Off
Load Balance Mode On
Health Check Invalidation
Watchdog Off
Query Cache On / shmem
TagsNo tags attached.

Activities

t-ishii

2013-07-05 09:18

developer   ~0000303

The error messages says all. Have you installed pgpool_regclass?

patrickrodies

2013-07-05 15:33

reporter   ~0000304

You are correct; I did not as in the doc it was stipulated that ' Without this, handling of duplicate table names in different schema might cause trouble (temporary tables aren't a problem).'

I will try to see if it does resolve this issue. I am still confused of why I need them for this particular case?

Thanks for your prompt reply

t-ishii

2013-07-05 15:54

developer   ~0000305

If you did not install the function, you should not have gotten errors except you are just confused if you have same name tables in difference schemas as explained in the doc. This is a know problem with current pgpool-II 3.2 versions. Will be fixed in next release. We expect it happens in this month.

patrickrodies

2013-07-05 16:02

reporter   ~0000306

The problem is fixed after installing the pgpool_regclass, thanks

As for the error, we do not have any table with the same name in a different schema. That is why we did not install this extension.

On a different note, thanks a lot for a great software, are you planning a release for Freebsd port of next version?

t-ishii

2013-07-09 13:07

developer   ~0000307

It seems there is no FreeBSD enthusiast in the developers. Are you willing to become a pgpool port maintainer?

Issue History

Date Modified Username Field Change
2013-07-04 23:02 patrickrodies New Issue
2013-07-05 09:18 t-ishii Note Added: 0000303
2013-07-05 09:18 t-ishii Assigned To => t-ishii
2013-07-05 09:18 t-ishii Status new => feedback
2013-07-05 15:33 patrickrodies Note Added: 0000304
2013-07-05 15:33 patrickrodies Status feedback => assigned
2013-07-05 15:54 t-ishii Note Added: 0000305
2013-07-05 16:02 patrickrodies Note Added: 0000306
2013-07-09 13:07 t-ishii Note Added: 0000307
2013-07-19 10:35 t-ishii Status assigned => resolved