View Issue Details

IDProjectCategoryView StatusLast Update
0000487Pgpool-IIBugpublic2019-05-21 16:01
Reporterzaid shabbirAssigned Topengbo 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
Product Version4.0.3 
Target VersionFixed in Version 
Summary0000487: As a user, Not able to connect psql with pgpool port after server restart
DescriptionOn Centos 7 after the successful installation of pgpool 4.0.3 not able to connect psql with pgpool port 9999 due to ERROR: connection cache is full
Steps To Reproduce1. PG 11 server running with any authentication. Now install edb-pgpool3.7.8 or edb-pgpool4.0.3
2. Configure pgpool and launch pgpool process.
3. psql connection established successfully with pgpool port 9999
4. Now stop Postgressql-11 service and try to connect psql with 9999 port
  /usr/edb/as11/bin/psql -d edb -p 9999 -U enterprisedb -c "select version";
psql.bin: FATAL: failed to create a backend connection
DETAIL: executing failover on backend

5. Again start edb-as-11 service { systemctl start edb-as-11 }
6. Execute psql command

/usr/edb/as11/bin/psql -d edb -p 9999 -U enterprisedb -c "select version";
psql.bin: ERROR: connection cache is full
HINT: increase max_pool
Additional InformationWorkaround:

After pgpool process restart above issue not reproducible
TagsNo tags attached.

Activities

pengbo

2019-03-31 23:26

developer   ~0002489

Could you show pgpool.conf?

zaid shabbir

2019-04-02 15:36

reporter  

pgpool.conf (38,445 bytes)

zaid shabbir

2019-04-02 15:38

reporter   ~0002501

The problem is with the error message thrown by the Pgpool-II for the case when all backend nodes are down.
As far as the severity of the issue is concerned it can be categorized as a minor inconvenience.

The only problem is with this wrong error message. Currently invalid error message only happens when we enable the ssl in pgpool.conf (ssl = on).

pengbo

2019-04-07 22:55

developer   ~0002535

I could not reproduce this issue.
Did this problem only occur with edb?

Could you try if this issue occurred with PostgreSQL?

pengbo

2019-05-09 17:38

developer   ~0002593

Thank you.
I have fixed this error message.
https://git.postgresql.org/gitweb?p=pgpool2.git;a=commitdiff;h=6e925e84a8cc49d724395471d14b2dc6af9ac07e

Issue History

Date Modified Username Field Change
2019-03-27 18:54 zaid shabbir New Issue
2019-03-31 23:26 pengbo Note Added: 0002489
2019-03-31 23:26 pengbo Assigned To => pengbo
2019-03-31 23:26 pengbo Status new => assigned
2019-04-02 15:36 zaid shabbir File Added: pgpool.conf
2019-04-02 15:38 zaid shabbir Note Added: 0002501
2019-04-07 22:55 pengbo Note Added: 0002535
2019-04-07 22:55 pengbo Status assigned => feedback
2019-05-09 17:38 pengbo Note Added: 0002593
2019-05-21 16:01 administrator Status feedback => closed