View Issue Details

IDProjectCategoryView StatusLast Update
0000401Pgpool-IIBugpublic2018-06-04 12:40
ReporterPeruzzoAssigned To 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionopen 
PlatformLinuxOSUbuntuOS Version16.04 LTS
Product Version3.7.2 
Target VersionFixed in Version 
Summary0000401: PCP commands requesting a password even with .pcppass file
DescriptionI created a ~/.pcppass with my credentials but with any commando (eg: pcp_node_info) my password is still requested. If I use the "-w" option or just press enter the command finishes as expected.
The expected behaviour (IMHO) is to prompt the password only if the file is not present
Steps To ReproduceCreate the .pcppass file (with the required permissions) and execute any command (eg: pcp_node_info 0), the prompt will be presented
TagsNo tags attached.

Activities

pengbo

2018-05-29 10:15

developer   ~0002033

It seems worked by me.
Did you create the .pcppass file in user's home directory?


[pengbo@localhost pgpoolsetup]$ pgpool -v
pgpool-II version 3.7.2 (amefuriboshi)

[pengbo@localhost pgpoolsetup]$ ll /home/pengbo/.pcppass
-rw------- 1 pengbo pengbo 30 5月 29 10:07 /home/pengbo/.pcppass

[pengbo@localhost pgpoolsetup]$ pcp_node_info -n 0 -p 11001 -U pengbo -w
/tmp 11002 1 0.500000 waiting primary

Peruzzo

2018-05-29 21:58

reporter   ~0002035

I believe that "-w" is just to force to not ask for the password, if you don't specify AND there is a match in .pcppass it should not ask for the credentials.

ubuntu@brapsql1:~$ pgpool -v
pgpool-II version 3.7.2 (amefuriboshi)

ubuntu@brapsql1:~$ ls -l ~/.pcppass
-rw------- 1 ubuntu ubuntu 23 May 28 14:10 /home/ubuntu/.pcppass

ubuntu@brapsql1:~$ pcp_node_info -h localhost -n 0
Password: <I just press enter here, without suplying a password)
10.211.5.180 5432 2 0.058824 up primary

pengbo

2018-05-30 09:48

developer   ~0002037

This is the feature of pcp commands. To never prompt for password you have to use "-w" option.

pengbo

2018-06-04 12:40

developer   ~0002039

Shall we close this issue, because it is not a bug.

Issue History

Date Modified Username Field Change
2018-05-29 01:55 Peruzzo New Issue
2018-05-29 10:15 pengbo Note Added: 0002033
2018-05-29 21:58 Peruzzo Note Added: 0002035
2018-05-30 09:48 pengbo Note Added: 0002037
2018-06-04 12:40 pengbo Status new => resolved
2018-06-04 12:40 pengbo Note Added: 0002039