View Issue Details

IDProjectCategoryView StatusLast Update
0000386Pgpool-IIBugpublic2018-05-01 08:45
ReporteratanAssigned Topengbo 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionopen 
Platformx86_64OSCentosOS Version7
Product Version3.7.2 
Target VersionFixed in Version 
Summary0000386: Pgpool fails to start with a watchdog error
DescriptionThis is a copy of 0000382 that is in a wrong project.

I've been using two pgpool instances with two (master/slave) backends on two server for about one year. A couple of days ago there was a network failure, after that both pgpool instances shut down and are not able to start again. Both backends are good. They are accessed directly now. I also tried to upgrade to the latest 3.7.2 (was 3.6.x) version with a completely new configuration file made from scratch using master/slave template. It doesn't help, it just shut downs. Both configuration file and log file are attached.
TagsNo tags attached.

Activities

atan

2018-03-15 21:45

reporter  

pgpool_bug.conf (35,623 bytes)
pgpool_bug.log (93,481 bytes)

pengbo

2018-03-16 10:00

developer   ~0001966

In Pgpool-II 3.7.x, the new per node health check parameters are added.
You also need to set the following parameters:
    health_check_period0 = 0
    health_check_timeout0 = 20
    health_check_user0 = 'nobody'
    health_check_password0 = ''
    health_check_database0 = ''
    health_check_max_retries0 = 0
    health_check_retry_delay0 = 1
    connect_timeout0 = 10000

See more details:
http://www.pgpool.net/docs/latest/en/html/runtime-config-health-check.html


#------------------------------------------------------------------------------
# HEALTH CHECK GLOBAL PARAMETERS
#------------------------------------------------------------------------------

health_check_period = 10
                                   # Health check period
                                   # Disabled (0) by default
health_check_timeout = 20
                                   # Health check timeout
                                   # 0 means no timeout
health_check_user = 'pgpool'
                                   # Health check user
health_check_password = '*****'
                                   # Password for health check user
health_check_database = ''
                                   # Database name for health check. If '', tries 'postgres' frist,
health_check_max_retries = 0
                                   # Maximum number of times to retry a failed health check before giving up.
health_check_retry_delay = 1
                                   # Amount of time to wait (in seconds) between retries.
connect_timeout = 10000
                                   # Timeout value in milliseconds before giving up to connect to backend.
                                   # Default is 10000 ms (10 second). Flaky network user may want to increase
                                   # the value. 0 means no timeout.
                                   # Note that this value is not only used for health check,
                                   # but also for ordinary conection to backend.

#------------------------------------------------------------------------------
# HEALTH CHECK PER NODE PARAMETERS (OPTIONAL)
#------------------------------------------------------------------------------
health_check_period0 = 0
health_check_timeout0 = 20
health_check_user0 = 'nobody'
health_check_password0 = ''
health_check_database0 = ''
health_check_max_retries0 = 0
health_check_retry_delay0 = 1
connect_timeout0 = 10000

pengbo

2018-04-27 11:58

developer   ~0002004

If the problem is already resolved, may I close this issue?

Issue History

Date Modified Username Field Change
2018-03-15 21:45 atan New Issue
2018-03-15 21:45 atan File Added: pgpool_bug.log
2018-03-15 21:45 atan File Added: pgpool_bug.conf
2018-03-16 10:00 pengbo Note Added: 0001966
2018-03-16 10:00 pengbo Assigned To => pengbo
2018-03-16 10:00 pengbo Status new => assigned
2018-04-27 11:58 pengbo Note Added: 0002004
2018-05-01 08:45 pengbo Status assigned => closed