View Issue Details

IDProjectCategoryView StatusLast Update
0000299Pgpool-IIBugpublic2017-08-29 09:50
Reportersupp_kAssigned ToMuhammad Usama 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
Platformx86_64OSCentOSOS Version7.X
Product Version3.6.2 
Target VersionFixed in Version 
Summary0000299: Errors on the reloading of configuration
DescriptionThe "reload" command leads to appearing of errors in pgpool log file. I assume that the configuration is not reloaded too.

Just "start" pgpool as systemd service and "reload". Obviously pgpool considers default location of its configuration files. But it fails when locations are specified in OPTS variable in the file "/etc/sysconfig/pgpool".

Errors:
1) pool_hba is considered in different location though it was specified on the service startup: # /usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf -F /etc/pgpool-II/pcp.conf -a /etc/pgpool-
II/pool_hba.conf -f /etc/pgpool-II/pgpool.conf
   
   Message: "failed while loading hba configuration from file:"/usr/local/etc/pool_hba.conf"

2) The error states "debug_level" parameter is incorrect
   Message: "unrecognized configuration parameter "debug_level"

Please see the log data of pgpool.
Steps To ReproduceSpecify location of pgpool configuration parameters for instance like:
/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf -F /etc/pgpool-II/pcp.conf -a /etc/pgpool-II/pool_hba.conf -f /etc/pgpool-II/pgpool.conf


Start pgpool as: "/bin/systemctl start pgpool.service"


Reload pgpool as: "/bin/systemctl reload pgpool.service" ..and the errors will appear:

2017-04-06T17:46:13.278095+03:00 OAA-a01149b7a559 journal: orker process[2053]: [26-2] LOCATION: pool_config_variables.c:2408
2017-04-06T17:48:47.564227+03:00 OAA-a01149b7a559 pgpool[2085]: [6-1] WARNING: failed while loading hba configuration from file:"/usr/local/etc/pool_hba.conf"
2017-04-06T17:48:47.564305+03:00 OAA-a01149b7a559 pgpool[2085]: [6-2] DETAIL: fopen failed with error: "No such file or directory"
2017-04-06T17:48:47.564432+03:00 OAA-a01149b7a559 pgpool[2085]: [6-3] LOCATION: pool_hba.c:111
2017-04-06T17:48:47.564526+03:00 OAA-a01149b7a559 pgpool[1994]: [229-1] LOG: reload config files.
2017-04-06T17:48:47.564656+03:00 OAA-a01149b7a559 pgpool[1994]: [229-2] LOCATION: pgpool_main.c:3375
2017-04-06T17:48:47.565207+03:00 OAA-a01149b7a559 pgpool[1994]: [232-1] INFO: unrecognized configuration parameter "debug_level"
2017-04-06T17:48:47.565318+03:00 OAA-a01149b7a559 pgpool[1994]: [232-2] LOCATION: pool_config_variables.c:2408
2017-04-06T17:48:47.567832+03:00 OAA-a01149b7a559 journal: orker process[2053]: [33-1] LOG: reloading config file
2017-04-06T17:48:47.567962+03:00 OAA-a01149b7a559 journal: orker process[2053]: [33-2] LOCATION: pool_worker_child.c:444
2017-04-06T17:48:47.568496+03:00 OAA-a01149b7a559 journal: orker process[2053]: [36-1] INFO: unrecognized configuration parameter "debug_level"
2017-04-06T17:48:47.568603+03:00 OAA-a01149b7a559 journal: orker process[2053]: [36-2] LOCATION: pool_config_variables.c:2408
TagsNo tags attached.

Activities

supp_k

2017-04-06 23:59

reporter  

pgpool.conf (4,192 bytes)

elepuser

2017-04-12 16:36

reporter   ~0001412

Hi Guys,

I have faced the same issue. If alternative configuration is used then it is impossible to reload the pgpool, only restart helps. This is unacceptable because pgpool act as the database layer.

Muhammad Usama

2017-04-12 23:48

developer   ~0001413

Thanks for reporting the issue. I have pushed the fix in all supported branches.

https://git.postgresql.org/gitweb/?p=pgpool2.git;a=commitdiff;h=f5f42befc1d12d73abdcddb9a9f9c0ca14722994

The problem was in the code path that sends the signal to the running Pgpool-II process asking for reload the configuration. And the warning "failed while loading hba configuration" was thrown by process that sends the signal and the running Pgpool-II process actually loads the correct configuration files even with this warning.

supp_k

2017-04-13 05:26

reporter   ~0001414

Muhammad,
with the patch the primary message regarding incorrect location of pool_hba.conf file disappeared.

But the message regarding incorrect "debug_level" parameter still exists.
Should it be like this?

Apr 12 23:22:59 OAB-0b8c777629f8 [11476]: [156-1] LOG: reload config files.
Apr 12 23:22:59 OAB-0b8c777629f8 [11476]: [156-2] LOCATION: pgpool_main.c:3451
Apr 12 23:22:59 OAB-0b8c777629f8 [11476]: [358-1] INFO: unrecognized configuration parameter "debug_level"
Apr 12 23:22:59 OAB-0b8c777629f8 [11476]: [358-2] LOCATION: pool_config_variables.c:2408
Apr 12 23:22:59 OAB-0b8c777629f8 [11723]: [155-1] LOG: reloading config file

Muhammad Usama

2017-04-13 19:06

developer   ~0001415

Yes basically debug_level configuration parameter has given the way to new log related configurations (server|client)_min_messages since Pgpool-II 3.4, And it is not supported anymore by Pgpool-II.
So "unrecognized configuration parameter debug_level" info is correct because the pgpool.conf file is trying to set debug_level.
I think the problem is with the documentation which needs to be updated to clearly state the removal of old debug_level configuration in favour of (server|client)_min_messages configuration parameters.

supp_k

2017-04-13 20:12

reporter   ~0001417

Muhammad,
ok, I see now that is not a problem!

Just wonder about implications of this message. Does it impact the completeness of the whole reload procedure?

Muhammad Usama

2017-04-13 23:21

developer   ~0001418

No I does not have any effect other than producing an annoying info message and can be safely ignored.

supp_k

2017-04-14 04:48

reporter   ~0001419

Muhammad,

ok, thank you! I'll just remove the parameter or mark it as obsolete.

P/S: Probably it makes sense to remove the parameter from pgpool configuration samples.

Issue History

Date Modified Username Field Change
2017-04-06 23:59 supp_k New Issue
2017-04-06 23:59 supp_k File Added: pgpool.conf
2017-04-07 15:45 t-ishii Assigned To => Muhammad Usama
2017-04-07 15:45 t-ishii Status new => assigned
2017-04-12 16:36 elepuser Note Added: 0001412
2017-04-12 23:48 Muhammad Usama Status assigned => resolved
2017-04-12 23:48 Muhammad Usama Resolution open => fixed
2017-04-12 23:48 Muhammad Usama Note Added: 0001413
2017-04-13 05:26 supp_k Status resolved => feedback
2017-04-13 05:26 supp_k Resolution fixed => reopened
2017-04-13 05:26 supp_k Note Added: 0001414
2017-04-13 19:06 Muhammad Usama Note Added: 0001415
2017-04-13 20:12 supp_k Note Added: 0001417
2017-04-13 20:12 supp_k Status feedback => assigned
2017-04-13 23:21 Muhammad Usama Note Added: 0001418
2017-04-14 04:48 supp_k Note Added: 0001419
2017-08-29 09:50 pengbo Status assigned => closed