View Issue Details

IDProjectCategoryView StatusLast Update
0000232Pgpool-IIBugpublic2016-08-15 09:47
Reportert-ishiiAssigned ToMuhammad Usama 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
PlatformLinuxOSUbuntuOS Version14.04
Product Version3.5.3 
Target VersionFixed in Version 
Summary0000232: pcp_stop_pgpool emit an error message: ERROR: unable to read data from socket.
DescriptionWhen pcp_stop_pgpool executes, it always complain "ERROR: unable to read data from socket." even if it successfully stopped Pgpool-II.
Steps To Reproduce$ pcp_stop_pgpool -p 11001 -m f
Password:
ERROR: unable to read data from socket.
Tagspcp commands

Activities

Muhammad Usama

2016-08-12 23:01

developer   ~0000988

Hi Ishii-San

I am not able to reproduce the issue, Can you please share the debug log of the utility.
Also can you verify that you are using the correct PCP port, Because while testing I accidentally specified pgpool server port instead of PCP port and got the same error as yours.


[usama@localhost bin]$ ./pcp_stop_pgpool -h 127.0.0.1 -p 9891 -U postgres -d -m f
Password:
DEBUG: recv: tos="m", len=8
DEBUG: recv: tos="r", len=21
DEBUG: send: tos="T", len=5
DEBUG: recv: tos="t", len=20
pcp_stop_pgpool -- Command Successful
DEBUG: send: tos="X", len=4
[usama@localhost bin]$ ./pcp_stop_pgpool -h 127.0.0.1 -p 9891 -U postgres -m f
Password:
pcp_stop_pgpool -- Command Successful
[usama@localhost bin]$ ./pcp_stop_pgpool -h 127.0.0.1 -p 9891 -U postgres -m s
Password:
pcp_stop_pgpool -- Command Successful

t-ishii

2016-08-15 09:47

developer   ~0000990

For some reasons I don't know, I cannot reproduce the problem any more.
Issue closed for now. I will reopen once I succeed to reproduce the issue.

Issue History

Date Modified Username Field Change
2016-08-10 17:25 t-ishii New Issue
2016-08-10 17:25 t-ishii Tag Attached: pcp commands
2016-08-10 17:26 t-ishii Assigned To => Muhammad Usama
2016-08-10 17:26 t-ishii Status new => assigned
2016-08-12 23:01 Muhammad Usama Status assigned => feedback
2016-08-12 23:01 Muhammad Usama Note Added: 0000988
2016-08-15 09:47 t-ishii Note Added: 0000990
2016-08-15 09:47 t-ishii Status feedback => assigned
2016-08-15 09:47 t-ishii Status assigned => closed