View Issue Details

IDProjectCategoryView StatusLast Update
0000002Pgpool-IIBugpublic2012-02-14 16:29
ReportertuomasAssigned Tot-ishii 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionopen 
PlatformOSUbuntuOS Version11.04
Product Version 
Target VersionFixed in Version 
Summary0000002: Client connection hangs in daemon mode
DescriptionThe issues happens at least with md5 pool authentication enabled

pgpool version 3.1.2
postgresql 9.1

pg_hba.conf:
host all all 0.0.0.0/0 md5

pool_hba.conf:
host all all 0.0.0.0/0 md5

pgpool.conf:
streaming master-slave configuration is used. ssl = off in pgpool and server.
enable_pool_hba = on
authentication_timeout = 5

user/password pair generated by pg_md5 is in pool_passwd.

when trying to connect to pgpool, by i.e.
$ psql --host=127.0.0.1 --user=username -d template1

The "pgpool: accept connection" and the psql process just hang up forever. Nothing happens, no errors in pgpool or stdout/err.

In postgresql server log is an error:
2012-02-06 13:15:38.636 UTC LOG: connection received: host=10.x.x.x port=45207
2012-02-06 13:15:38.639 UTC LOG: could not receive data from client: Connection reset by peer
2012-02-06 13:15:38.639 UTC LOG: unexpected EOF within message length word

In debug mode I get the following to syslog:
Feb 6 13:33:57 qa01 pgpool[18845]: I am 18845 accept fd 6
Feb 6 13:33:57 qa01 pgpool[18845]: connection received: host=localhost port=46606
Feb 6 13:33:57 qa01 pgpool[18845]: Protocol Major: 1234 Minor: 5679 database: user:
Feb 6 13:33:57 qa01 pgpool[18845]: SSLRequest from client
Feb 6 13:33:57 qa01 pgpool[18845]: pool_ssl: SSL requested but SSL support is not available
Feb 6 13:33:57 qa01 pgpool[18845]: read_startup_packet: application_name: psql
Feb 6 13:33:57 qa01 pgpool[18845]: Protocol Major: 3 Minor: 0 database: yyy user: xxx

Nothing after that.

Strangely enough, everything seem to work fine if i run pgpool in foreground mode with -n.



TagsNo tags attached.

Activities

tuomas

2012-02-11 19:23

reporter   ~0000004

This seems to happen also in foreground mode when for example, there are no backends available or when pgpool has received smart shutdown request but doesn't shutdown because of the other bug i reported. Clients just hang there forever. There are possibly some other cases where this might happen, too.

t-ishii

2012-02-14 16:29

developer   ~0000006

Fix committed to master and 3.1 STABLE. So fix will appear in pgpool-II 3.2 and 3.1.3.

Issue History

Date Modified Username Field Change
2012-02-06 22:39 tuomas New Issue
2012-02-11 19:23 tuomas Note Added: 0000004
2012-02-14 16:20 t-ishii Assigned To => t-ishii
2012-02-14 16:20 t-ishii Status new => assigned
2012-02-14 16:29 t-ishii Note Added: 0000006
2012-02-14 16:29 t-ishii Status assigned => resolved