View Issue Details

IDProjectCategoryView StatusLast Update
0000142Pgpool-IIIncompatible changepublic2015-08-21 10:53
ReporterdavecramerAssigned Tonagata 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform64bitOSlinuxOS Versionamazon ami
Product Version 
Target VersionFixed in Version 
Summary0000142: rpm's require libmemcache 2
Descriptioncan't find libmemcache 2 rpms
TagsNo tags attached.

Activities

nagata

2015-08-14 14:20

developer   ~0000549

Where did you get the rpm? Rpms in our official repository (http://www.pgpool.net/yum/)
require libmemcache-0.31, which is available by yum command of CentOS6 (I think it is same as RHEL6).
If you got the rpm from PostgreSQL's official repository (http://yum.postgresql.org/), this requires libmemcache-1.0.17, which is also available from the PostgreSQL official repo.

davecramer

2015-08-14 19:59

reporter   ~0000552

I installed your yum location and then used yum

yum install pgpool-II-pg94
Failed to set locale, defaulting to C
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest | 2.1 kB 00:00
amzn-updates/latest | 2.3 kB 00:00
pgdg94/x86_64 | 3.6 kB 00:00
pgpool33/x86_64 | 1.3 kB 00:00
24 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package pgpool-II-pg94.x86_64 0:3.3.7-1pgdg.rhel6 will be installed
--> Processing Dependency: libmemcached.so.2(libmemcached_2)(64bit) for package: pgpool-II-pg94-3.3.7-1pgdg.rhel6.x86_64
--> Processing Dependency: libmemcached.so.2()(64bit) for package: pgpool-II-pg94-3.3.7-1pgdg.rhel6.x86_64
--> Finished Dependency Resolution
Error: Package: pgpool-II-pg94-3.3.7-1pgdg.rhel6.x86_64 (pgpool33)
           Requires: libmemcached.so.2(libmemcached_2)(64bit)
Error: Package: pgpool-II-pg94-3.3.7-1pgdg.rhel6.x86_64 (pgpool33)
           Requires: libmemcached.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

nagata

2015-08-17 16:40

developer   ~0000553

Hmm... It seems that Amazon ami's repository provides libememcached.so.11 indead of libmemcached.so.2.

Did you use http://www.pgpool.net/yum/rpms/3.3/redhat/rhel-6-x86_64/pgpool-II-release-3.3-1.noarch.rpm to install our repository?
If so, using http://www.pgpool.net/yum/rpms/3.3/redhat/rhel-7-x86_64/pgpool-II-release-3.3-1.noarch.rpm might resolve it, since RPMs for RHEL7 uses libmemcahced.so.11.

davecramer

2015-08-17 20:46

reporter   ~0000554

FWIW, the link above 404's

But using rel-7 just gives more problems

Error: Package: pgpool-II-pg94-3.3.7-1pgdg.rhel7.x86_64 (pgpool33)
           Requires: systemd
Error: Package: pgpool-II-pg94-3.3.7-1pgdg.rhel7.x86_64 (pgpool33)
           Requires: libmemcached.so.11()(64bit)
Error: Package: pgpool-II-pg94-3.3.7-1pgdg.rhel7.x86_64 (pgpool33)
           Requires: systemd-sysv

nagata

2015-08-18 15:39

developer   ~0000555

I'm sorry for URL typo.

I don't know which is suitable to use for your Amazon linux ami, rhel6 or rhel7.
It might seem to be better to use rhel6 since systemd packages aren't required.
Anyway, libmemcached of a certain version is required for installing pgpool-II
rpm and yum command should resolve the dependency. I don't know also why yum
fails.

Could you try "yum install libmemcached"? If this fails, you can try to install
libmemcached from rpm file directly.
http://mirror.centos.org/centos/6/os/x86_64/Packages/libmemcached-0.31-1.1.el6.x86_64.rpm

davecramer

2015-08-20 19:59

reporter   ~0000557

Manually installing libmemcached and your rpms works. Thanks

nagata

2015-08-21 10:53

developer   ~0000558

I'm glad to hear that. Thanks.

Issue History

Date Modified Username Field Change
2015-08-12 21:42 davecramer New Issue
2015-08-14 13:40 nagata Assigned To => nagata
2015-08-14 13:40 nagata Status new => assigned
2015-08-14 14:20 nagata Note Added: 0000549
2015-08-14 14:20 nagata Status assigned => feedback
2015-08-14 19:59 davecramer Note Added: 0000552
2015-08-14 19:59 davecramer Status feedback => assigned
2015-08-17 16:40 nagata Note Added: 0000553
2015-08-17 17:00 nagata Status assigned => feedback
2015-08-17 20:46 davecramer Note Added: 0000554
2015-08-17 20:46 davecramer Status feedback => assigned
2015-08-18 15:39 nagata Note Added: 0000555
2015-08-20 10:28 nagata Status assigned => feedback
2015-08-20 19:59 davecramer Note Added: 0000557
2015-08-20 19:59 davecramer Status feedback => assigned
2015-08-21 10:53 nagata Note Added: 0000558
2015-08-21 10:53 nagata Status assigned => resolved
2015-08-21 10:53 nagata Resolution open => fixed