View Issue Details

IDProjectCategoryView StatusLast Update
0000139Pgpool-IIBugpublic2015-11-18 23:11
ReporterrobeAssigned ToMuhammad Usama 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000139: broken arping_cmd doesn't get reported in pgpool 3.3.6
DescriptionWhen having a misconfigured arping_cmd this isn't caught by pgpool 3.3.6:

Jul 17 12:16:42 off-zk-02-ber pgpool: 2015-07-17 12:16:42 DEBUG: pid 21801: exec_ifconfig: 'pgpool_ifconfig eth0:pgpool2-slow inet $_IP_$ netmask 255.255.255.0' succeeded
Jul 17 12:16:42 off-zk-02-ber pgpool: 2015-07-17 12:16:42 DEBUG: pid 21801: exec_ifconfig: 'arping -U -I eth0 -c 10 $_IP_$' succeeded
[..]
Jul 17 12:16:44 off-zk-02-ber pgpool: 2015-07-17 12:16:44 LOG: pid 21801: wd_IP_up: ifconfig up succeeded

But when looking at a strace of the watchdog process it clearly shows the misconfigured arping path:

execve("/usr/sbin/arping", ["arping", "-U", "-I", "eth0", "-c", "10", "192.168.181.232"], [/* 18 vars */]) = -1 ENOENT (No such file or directory)
TagsNo tags attached.

Activities

Muhammad Usama

2015-11-18 23:11

developer   ~0000596

Hi,
Thanks for the report.

I have committed the fix
http://git.postgresql.org/gitweb/?p=pgpool2.git;a=commit;h=9db32fe4486068e15a9afe478485e8b01fcd40ae

Best regards!

Issue History

Date Modified Username Field Change
2015-07-17 19:27 robe New Issue
2015-08-04 10:10 t-ishii Assigned To => Muhammad Usama
2015-08-04 10:10 t-ishii Status new => assigned
2015-11-18 23:11 Muhammad Usama Note Added: 0000596
2015-11-18 23:11 Muhammad Usama Status assigned => resolved
2015-11-18 23:11 Muhammad Usama Resolution open => fixed