View Issue Details

IDProjectCategoryView StatusLast Update
0000123Pgpool-IIBugpublic2018-07-06 13:38
ReporterravazzoloAssigned Tot-ishii 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionopen 
PlatformLinuxOSDebianOS VersionDebian 3.2.63-2
Product Version 
Target VersionFixed in Version 
Summary0000123: MD5 authentication is not requiring password.
DescriptionMD5 authentication is not requiring password. It checks the user in pool_password file, but accepts null passwords and wrong passwords.

Environment:
Two servers PostgreSQL 9.1 and pgpool-II 3.4.0, running as MASTER/SLAVE mode and streaming replication. See configuration files attached.

It was tested with pgpool-II 3.2.5 and 3.3.3, same problem occurs.

I've been reviewing the configuration files and seems to be all right. I don't know if I'm missing something.

Thanks!

Ricardo Ravazzolo
Steps To ReproduceCreate a user/password in PostgreSQL.

Update pool_passwd file using pg_md5 and specifying the same user/password created in PostgreSQL.

Add entries in pool_hba.conf and pg_hba.conf of md5 type.

Reload PostgreSQL and pgpool.

Try to connect using pgpool port, informing user without password. It works for me.
TagsNo tags attached.

Activities

ravazzolo

2014-12-02 06:48

reporter  

pgpool.zip (16,641 bytes)

t-ishii

2014-12-02 08:19

developer   ~0000498

Which IP is pgpool running on? It should match with the one specified in pg_hba.conf.

ravazzolo

2014-12-02 23:46

reporter   ~0000500

Sorry, I'm using two servers, both running PostgreSQL and Pgpool.

Pgpool is running in the same servers of PostgreSQL, IPs 10.10.1.35 and 10.10.1.36.

HBA files are equal in both servers.

t-ishii

2014-12-03 08:25

developer   ~0000501

Followings in pg_hba.conf allow pgpool to access PostgreSQL without password.

host all all 10.10.1.35/32 trust
host all all 10.10.1.36/32 trust

ravazzolo

2014-12-08 22:09

reporter   ~0000502

Problem solved, pg_hba.conf was changed on both servers with the following entries for pgpool:
host all all 10.10.1.35/32 md5
host all all 10.10.1.36/32 md5

Sorry about spending your time, I'm new with Pgpool and PostgreSQL.

Thanks for agility in responding!

Ricardo Ravazzolo

Issue History

Date Modified Username Field Change
2014-12-02 06:48 ravazzolo New Issue
2014-12-02 06:48 ravazzolo File Added: pgpool.zip
2014-12-02 08:13 t-ishii Assigned To => t-ishii
2014-12-02 08:13 t-ishii Status new => feedback
2014-12-02 08:13 t-ishii Steps to Reproduce Updated View Revisions
2014-12-02 08:19 t-ishii Note Added: 0000498
2014-12-02 23:46 ravazzolo Note Added: 0000500
2014-12-02 23:46 ravazzolo Status feedback => assigned
2014-12-03 08:25 t-ishii Note Added: 0000501
2014-12-08 22:09 ravazzolo Note Added: 0000502
2018-07-06 13:38 t-ishii Status assigned => resolved