View Issue Details

IDProjectCategoryView StatusLast Update
0000120Pgpool-IIBugpublic2014-11-06 08:06
ReportereldadAssigned ToMuhammad Usama 
PriorityhighSeveritymajorReproducibilityalways
Status assignedResolutionopen 
PlatformLinuxOSRHELOS Version6.3
Product Version 
Target VersionFixed in Version 
Summary0000120: Standby pgpool fail to start after failover
DescriptionI have pgpool II 3.3.4 installation with active-standby configuration.
pgpool is working well on both and once I stop the servie on the active node the fail over is completed successfully.
the problem is that once I start the service on the node that was the active node the pgpool fail to start.
only the mail process exists and in the debug messages it stops after the successful ping to the second node.
strace show futex wait.
not other process exists (watchdog, lifecheck etc.)
I used heartbeat method but it also happened in query mode.

* Note - same configuration with the same servers running pgpool II 3.3.3 works.
Steps To ReproduceCreate pgpool active-standby installation
Stop service on the active node and wait for failover to complete,
then start the node again (should start as standby).
Additional Informationpgpool II 3.3.4
streaming replication
postgres 9.3.3 with 4 nodes.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-11-05 21:35 eldad New Issue
2014-11-06 08:06 t-ishii Assigned To => Muhammad Usama
2014-11-06 08:06 t-ishii Status new => assigned