View Issue Details

IDProjectCategoryView StatusLast Update
0000112Pgpool-IIBugpublic2014-08-22 07:49
ReporterekassAssigned Tot-ishii 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionopen 
Platformamd64OSDebianOS VersionWheezy
Product Version 
Target VersionFixed in Version 
Summary0000112: Pgpool reports wrong primary node
Descriptionpgpool2 v.3.3.3 with postgresql-9.3
pgpool2 configured in master slave mode with streaming replication

If pgpool has a primary node which is not also the master it doesn't recognise the primary. In this way I can't build a correct failover script.
Steps To ReproducePgpool admin correctly reports this:

node 0: up standby
node 1: up primary
node 2: up standby

The node recognised as old primary (%P) in case of 0's failover is node 0, which is the old master node. Shouldn't pgpool always recognise the actual primary node and not assume that master node is also the primary? Or the above backend order is not supported?
TagsNo tags attached.

Activities

t-ishii

2014-08-20 23:28

developer   ~0000462

pgpool-II 3.3.3 has known problem with this. Can you please use 3.3.3-stable head?

ekass

2014-08-21 01:34

reporter   ~0000463

I have built it from source from the official site about 2 months ago because I wanted ssl too. Should I re-download and build? I don't know how to find the 3.3.3-stable..

t-ishii

2014-08-21 09:25

developer   ~0000465

pgpool-II's git repository is here:
http://git.postgresql.org/gitweb/?p=pgpool2.git;a=summary
3.3-stable branch names is "V3_3_STABLE".

If you are not familiar with git, probably this is the easiest way:

1) visit: http://git.postgresql.org/gitweb/?p=pgpool2.git;a=shortlog;h=refs/heads/V3_3_STABLE
2) click "snapshot" button to down load 3.3-stable source tar ball. Upper line is more recent one.
3) unpack the tar file, cd into the directory type 'make dist'. This should create pgpool-II-3.3.3.tar.gz. Unpack it then build pgpool-II as usual.

ekass

2014-08-21 18:58

reporter   ~0000468

Ok, I faced a pid file issue initially, but it seems to be working correctly now with the stable 3.3.3. Thank you for the help.

Issue History

Date Modified Username Field Change
2014-08-20 20:32 ekass New Issue
2014-08-20 23:28 t-ishii Note Added: 0000462
2014-08-20 23:28 t-ishii Assigned To => t-ishii
2014-08-20 23:28 t-ishii Status new => assigned
2014-08-21 01:34 ekass Note Added: 0000463
2014-08-21 09:25 t-ishii Note Added: 0000465
2014-08-21 10:53 t-ishii Status assigned => feedback
2014-08-21 18:58 ekass Note Added: 0000468
2014-08-21 18:58 ekass Status feedback => assigned
2014-08-22 07:49 t-ishii Status assigned => resolved