View Revisions: Issue #566

Summary 0000566: Pgpool is not failing over compeltely to First node when 2nd and 3rd nodes were down
Revision 2019-12-12 17:48 by pengbo
Description We have 3 node PGPOOL-II with watchdog and repmgr configured.
3rd node became the primrary during failovers.
after we bring up First node , it is alwys giving below error.

Dec 10 16:19:17 rac01-prod pgpool[27256]: 2019-12-10 16:19:17: pid 27256: ERROR: failed to make persistent db connection
Dec 10 16:19:17 rac01-prod pgpool[27256]: 2019-12-10 16:19:17: pid 27256: DETAIL: connection to host:"rac03-prod:5432" failed
Dec 10 16:19:17 rac01-prod pgpool[27256]: 2019-12-10 16:19:17: pid 27256: LOG: find_primary_node: make_persistent_db_connection_noerror failed on node 2
Dec 10 16:19:20 rac01-prod pgpool[27256]: 2019-12-10 16:19:20: pid 27256: LOG: failed to connect to PostgreSQL server on "rac03-prod:5432", getsockopt() detected error "No route to host"
Revision 2019-12-11 06:21 by sureshreddy21
Description We have 3 node PGPOOL-II with watchdog and repmgr configured.
3rd node became the primrary during failovers.
after we bring up First node , it is alwys giving below error.

Dec 10 16:19:17 rac01-prod pgpool[27256]: 2019-12-10 16:19:17: pid 27256: ERROR: failed to make persistent db connection
Dec 10 16:19:17 rac01-prod pgpool[27256]: 2019-12-10 16:19:17: pid 27256: DETAIL: connection to host:"rac03-prod:5432" failed
Dec 10 16:19:17 rac01-prod pgpool[27256]: 2019-12-10 16:19:17: pid 27256: LOG: find_primary_node: make_persistent_db_connection_noerror failed on node 2
Dec 10 16:19:20 rac01-prod pgpool[27256]: 2019-12-10 16:19:20: pid 27256: LOG: failed to connect to PostgreSQL server on "rac03-prod:5432", getsockopt() detected error "No route to host"